"Dissolve" prototype feature isn't working properly (mabey a Figma bug?)

This started happening today.

I was prototyping a simple button, but when a was setting the “Dissolve” property to “While hovering”, the color transition have a extrange and irritating delay.

I have set the transition time to 300ms, the default value. In the prototype preview (you know, when you press “Play”), when I hover the button it doesn’t show the smooth color transition the Dissolve property should have. What’s happening exactly is that when I hover nothing happen during an amount of time equivalent to the 300ms I have set, then when that time pass it just instantly change the button color.

Is this a bug of Figma or something?


Same thing happening to me right now. Dissolve does not seem to work - the instance changes after set duration with a hard transition.


I’ve had the same problem since yesterday morning. Smart animate seems to work normally. It’s just a problem with the dissolve effect.

1 Like

Also experiencing this recently - trying to transition a button state on hover and it’s just a hard transition with no transition duration.


I’m also running into this issue with ‘dissolve’ since the last Figma update.

When viewing the prototype it’s now just a hard transition from one to the next.


Getting this on my side too. Works in transitions between frames but not as part of of a component changing states :frowning:


Exactly! I found out too that Smart animate seems to work as the Dissolve was intended to do, but i don’t want to depend of smart animate for small things like a button hover color changes.

And in other old project files is happening the same thing.

Hope they fix this quick.

1 Like

Hi everyone and thank you for raising this. Our engineering team is actively investigating the issue to determine its root cause and working towards a solution.


Having the same issue here recently. Despite having “dissolve” applied, there’s kind of a slight delay and it pops straight into the other state instead of progressively changing as it used to.

But other than that, I’m facing many other issues I didn’t earlier:

  • I have a sidebar with many “menu buttons” components inside.
  • Each “menu button” component has 3 states (default, hover, active).
  • In the main “sidebar” component they’re all set to “default”.
  • In each view, I change to “active” the one being shown.
  • But in the prototype, they all show as “default” always even if I have it set to “active” for that view.

This wasn’t a problem before and if it was, I’d solve it by resetting all changes of the component in the views. But now not even resetting works.

Also, I have a button with a hover state, but when hovering in the prototype it won’t change ever change from its first state :man_shrugging:

Not sure if everything is related or not, but it used to work previously and all of a sudden I started having all these issues.


Actually, the last thing (the button that won’t update) was my fault :stuck_out_tongue: fixed it now, but the sidebar issue is still ongoing and I can’t figure out what’s the problem.

1 Like

Yeah I have time triggered dissolves for tickers that are choppy and transition ‘immediately’ from one to the next without being set to instant (I’ve checked). Also the preview scroll is jerky as are the hover interactions. Everything thing seems to ‘stick’ and stop and start. Dissolves and smart animations that were working fine are now a choppy and jerky. I can’t show this to a client and I need to so would have to export as static PDF pages which is massively regressive. PLEASE FIX this asap guys. Mid-fidelity prototyping is contingent upon basic hover and time triggered interactions being functional. When the basics of scrolling down a page, hover interactions or time triggered dissolves are not working this is a major issue. Appreciate things go wrong sometimes but looks like this has been going on for 4 days since this thread started.


Same issue for me regarding the dissolve animation not working properly.
But something is wrong with prototyping in general as I’ve noticed a lot of elements not functioning properly in presentation mode:
• Scroll is very slow
• Some button variants randomly change from a size M to a size L despite being the right size in prototyping and design
• Some button variants won’t display the right state despite being the right state in prototyping and design
• Image charging time is pretty long
• Dissolve animation not working
Has anyone had the same issues?
My internet connection is fine and I’ve never had this kind of trouble before with this file…

1 Like

This has happened to all my prototypes. Same glitch across them all.


Guys make sure you put in a bug report: https://help.figma.com/hc/en-us/articles/360041468234-Submit-a-bug-report

According to the Figma status page there are no incidents today or over the last week. That doesn’t concord with what’s going on in this thread so report it.

1 Like

Ive been dealing with the same thing. Just submitted a bug report.

1 Like

Hello everyone.

I fixed my issue of the components not displaying the right state of its elements (i.e. sidebar menus). The problem was related to the “State Management” of the prototype links for each button.

I had to manually enable “Reset component state” for each link so that when you click on the links, it resets the state of the sidebar and, thus, shows the one I have in each view. Now “active” elements remain active on each of the screens.

I believe this was introduced with the new State Management updates. If you have the same issue, check this out, it might solve it for you too :slight_smile:


Hi all,
Thank you for your patience while our engineers worked on resolving the issue you reported. We are pleased to inform you that the fix has been successfully released!
Please refresh Figma to ensure that you are using the fixed version.

If you continue to experience the issue, please let us know by filling this form: here

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.