Deleting layer name no longer sets its name to default

I used to use shortcuts to quickly rename frames/groups/etc. — this helped me maintain the structure clear (I’m obsessive but don’t have time to give a name to each entity)

Previously, it worked like this:
I used shortcut cmd + r → I pressed delete → I pressed enter — took me like 2 seconds & resulted in Frame 1321314636 becoming just Frame, for example

However, after the last update (I suggest?) this feature doesn’t work properly. Is there anyone who experienced this too? Did you manage to solve the problem?

Still don’t understand why Figma would change this, so prefer to think this a bug

3 Likes

Hey @daria.lobacheva, thank you for reaching out!

I tried to reproduce these steps and you’re right the layer names aren’t changing. However, I am not sure if this is an intended behaviour. Let me double check with the team and come back to you.

Appreciate your patience in the meantime!

1 Like

Met the same problem.

It’s pretty annoying without this previously behaviour, especially when you import some layers from a co-worker with very bad habit.

image

2 Likes

yeah, this is irritating! so sad I have to rename all manually

Thank you for your time! I’m looking forward to response

Hey everyone! I’ve got updates, the engineers have now confirmed this was unintentional and are working to resolve the problem. We hope the expected behaviour should return in the coming days and apologise for the inconvenience in the interim.

Thanks again for your help here and for your patience while the team investigates. Let me know if you have any follow up questions and I’ll be happy to assist. I’ll give an update once a fix has been implemented.

2 Likes

Thank you very much!

1 Like

Hey everyone, this issue has been fixed now! I was able to test this on my end as well and it works for me.

Please let me know if you’re still running into any issues!