Component within Component Animation Not Working

I am trying to create a product card for a store design I’m working on and I want to animate an “add to cart” component within the parent “product card” component". The add to cart animation is working fine on its own. But I can’t seem to get it to function properly once it’s nested within the product card. I’m sure I’m just missing something simple. Does anyone have an idea of what?



I have the same problem - it happened few hours ago - all nested components don’t work in presentation mode.


I’m having the same issue :frowning:


Same issue here, responding to get @figma’s attention. all interactions are broken aside from navigate on click. EVERYTHING is broken for me.


The same issue here, none of my interactive components work on any of my projects. @Figma_Support @Figma_Team @Figma-Designer

This is a pretty severe bug as it breaks all prototyping.


Yep, several of my designers have reported the same issue. It was working this morning, now all nested component prototyping is broken.

I’m having the same issue.

I can’t get any interactions to work in presentation mode either. I even tried some random examples from the Community, and they don’t run either.

I’m with the same problem. I’ve been thinking all afternoon that it would be some fault of mine but I’ve already seen that it wasn’t. Help @Figma-Designer @Figma_Support

Also started having this issue this afternoon.

/bump Yes, this started happening around 8 am PST

Same issue, @figma none of my interactive components work on any of my projects. Help please!

I thought I was getting crazy and did something wrong that my interactive components stopped working. So kind of a relieve to see others have the same problem. I’m sure @figma will solve it soon :sweat_smile:

I’m glad to hear that it’s not just me. Hopefully @figma will get this resolved soon!

Same issue. @Figma_Support

My prototype just broke in the last hour and I didn’t change anying.

Figma has been notified and they are diagnosing now.

1 Like

Hey All, this is a known bug that our team is proactively working on. We’ll keep you in the loop as we work on a fix!


Awesome! Thank you!


I am new to Figma and I ran into this issue pretty quickly. I have however found a bit of a workaround! It seems like if you have the animation component nested within the first component and either make it boolean or instance-swappable, the animation works in preview!

The bug has been fixed? Because I’m fighting with that at the moment :disappointed_relieved: