Component Text Instance Issue

I have created an input field component with one variant property named ‘State’. One state is labeled ‘Default’, while the other state is labeled ‘Input’. In the default state, the placeholder text is ‘Type here…’, while in the Input state, it is ‘Lorem Ipsum’. When I edit the text in the instance’s Input state to a different text or in the example as “Demo”, the changes are made, but I cannot see them in the prototype when I play it. I have tried reloading the prototype, restarting Figma, and restarting my PC, but none of these actions have resolved the issue. Is this a bug, or am I doing something wrong?




Hi, Mustafa.

It seems to be working fine on my end. Can you show a video how it looks like in your end?


Instance text is different, I have changed the instance text to “Demo” but that doesn’t reflect in the prototype.

Hi, Mustafa.

I see. I think that was a bug from the instances override, a lot of people has been flagging about it lately and there is still no news from it.

But, I can show you a work around it using variables and conditional prototyping if you are in at least Professional license.

1 Like