Bug Report: Type Settings -> Case breaks applied Text Style

Hello there :wave:
I stumbled upon a bug that breaks Text Styles.
If a Text has a Text Style applied to it you still have the ability to change some Type settings without detaching the style, for example resizing, text alignment or case.
When I change the case of a styled text (e.g. uppercase → lowercase) somehow the attached Text Style breaks / detaches automatically.

See video example:

The text style should still be intact and not be removed, therefore this is a bug.
Fix, please? :eyes:

By the way: This forum is missing a general Figma Bug category – sorry for falsely labeling my topic because of this.

I’m using Figma Desktop App version 116.5.18 on macOS Big Sur 11.7.1 (20G918) – Mac mini (M1, 2020)

1 Like

There is no bug here because the text case is a property of the text style.

General bugs must be reported to the support service by filling out the form at the link: Submit a bug report.

I think its new that the option to change the case actually appears when a style is used.
Thats probably new because it felt off to begin with. I used to create specific duplicated Text Styles for case changes like uppercase and it always bothered me that its not an Override. Same like text decorations (underline, strikethrough). I’m certain the option to change cases did not appear up until lately.

That’s right, before it was like this:

But Figma didn’t change anything regarding the style properties. That is, just as it was impossible to select a different text case or decorations without detaching the style, so it remained.

Not sure what you mean.
In the screenshot you’ve posted you see that every option that is strictly linked to the style is hidden in the menu. Such as cases. So that means that every option that remains can be changed no matter if a style is used or not.
Thats why I expected the same behavior from Cases because it appears in the menu now.

So still, it seems quite off that it appears under the context menu now and that could be a bug. A style should not detach itself without the user actively doing it by clicking the respective Detach Style icon.

I mean, the logic is the same, and the text case and decoration properties are still required style properties. That is, if you override any of these properties, it will detach the style.

But this does not negate the fact that you can use shortcuts and main menu items to change properties.

I understand your problem, but it’s still not a bug because Figma hasn’t announced any changes to text styles. If they said in the release that you can change the text case without detaching the style, but you encounter the opposite, then yes, it’s a bug. But not now.

+1 Hope this gets fixed


I submitted a bug report

Support says:

I have received feedback from our team internally who have confirmed that, unfortunately, this is a known limitation within Figma. Whilst this is currently a limitation within our system, we are constantly working away at improving our product and aim to make this possible in the future.
As I do not have an ETA as to when this will be rectified, I will set this ticket as solved, but please do not hesitate to reach out should you require any further assistance or have any further questions.

I’ll create a new Thread for a feature request and will close this one then (I actually cannot find how I can close my own topic).

Feel free to give this a vote or leave your feedback:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.