Auto-layout : Distribution option "Space Between" disappeared after variable update

Hey, I just made the Variable update and now the Distribution option in Auto Layout disappeared, which prevents me to apply a Space Between distribution to my frame.

Can we avoid this and is this normal ?

3 Likes

You can now switch spacing mode by clicking on the dropdown in the “gap” input, and select Auto.

You can also toggle between Auto or packed spacing mode by double clicking on the alignment grid.

8 Likes

Thanks a lot !

is X still a control for this ?

Yes. You can still click the alignment grid and press X to toggle.

1 Like

THANKS ! I may be wrong, but I have the impression that the Figma documentation is not up to date…

I find this :

If so, how do I get Figma to update their documentation along with the updates

Thank yout, buddy!

Thanks for reporting! I’ll let the team know and update the docs soon.

1 Like

Where is ‘gap’ input? Don’t see this option when selecting the parent autolayout group where “space between” used to live.

1 Like

Gap is the field to the left of the alignment box.
It used to be called “spacing between items” but it’s been renamed to gap to better align with CSS.

1 Like