An error occurred while loading the plugin environment

Hi there!

I published a plugin and am waiting for the review.
When I try to launch the In-development version, it starts without any problems, but when I choose the published version (the one in the review), I get: An error occurred while loading the plugin environment.

At the same time, I have another plugin that was successfully published, and I can open both versions without any errors.

Is there something I’m doing wrong, or is it expected to return this error before the plugin is published to the community?

Thank you.

Have you tried restarting Figma? Stuff like this happens sometimes.

Yeah, I tried several things, using Figma Beta and Figma Stable version of the app, restarting, logging out/in, restarting the machine, nothing seems to work. The problem persist.

In this case don’t worry about it, this is likely just a Figma bug (since it’s the environment failing and not your plugin)

Thank you, Gleb!

I faced same problem in Figma while loading plugin. I work online, Do not use any app or Figma software. What can I do now?

If reloading Figma doesn’t work for you, reach out to Figma support.

I don’t reload page when plugin loading. I run and wait for that wedges. it is taking to load minimum 4minutes and then show that error.

I had the same problem. I’m worried whether it will pass the review or not.

This is an issue in the plugins engine, not in your plugin, so it should be good.