Figma Support Forum

A JavaScript error occurred in the main process [can't open Figma, Windows 10]

Hi everyone,

I didn’t find any posts on this topic, so I’m asking for some help.

Today, a couple of hours ago, I started Figma on Windows 10 and it said there was an update available, so I installed it immediately. And since then I can’t open the program. When I tried to open the program an error window appeared. So I uninstalled Figma and tried to install it again. And now I can’t even install it. The same error window appears. (Even when I try to install it). What can I do? I’m working with system fonts so I can’t work on the browser (in the browser it works fine, it seems to be a problem with the Windows app).

This is the alert that appears:

2021-11-15 (2)

I tried to delete the AppData “Figma” folder, but nothing happens. I did that because I found some post online (on another site) that talked about electron apps and how they sometimes fail with that specific error and possible ways to fix it. But it didn’t work.

I don’t know what to do anymore.

I needed to work on a project ASAP. If anyone can help me it will be greatly appreciated.

1 Like

Okay, so here are some updates on the issue:

I reinstalled the operating system (I was THAT desperate). Still the same problem. That didn’t solve it. I don’t think it’s a problem with Windows anymore. I think there is something wrong with the latest version of Figma for desktop, at least on my machine.

1 Like

Report this to Figma support team via the bug report form.

What the **** is this?

http: ipic.su/img/img7/fs/Bezymyannyj.1637034773.jpg

I have already cleaned the computer news, but there are no such things! removed everything related to figma

What is this error after the update? Why are you crazy? and the problem does not occur !!!

How to solve this problem?

I have the same problem on window 10 today


Please help me, I can’t open the app.

I have the same problem, searched and installed JavaScript but nothing happened. It was working normally yesterday, but today there was an error.

Hi. Same problem :frowning:

Same issue. After app update the Javascript error pops up.

I’m facing the same problem, unable to reinstall the application on Windows 11 64Bit. Keep getting the same error.

The same problem appeared after today’s update.

Hey everyone, sorry about this. This should be fixed now. You’ll just need to delete and reinstall the desktop app from our site here: Download Figma Desktop Apps, Mobile Apps, and Font Installers

2 Likes

I have the same problem! Help!

Hi everyone,

I’m sorry for the late reply.

Problem fixed. I downloaded the latest version on the downloads section on the Figma website and it works now. It was definitely a problem with Figma. And they solved it quickly so cheers to them for that.

I regret reinstalling the entire operating system trying to solve the issue, I thought it was a problem with my installation of Windows (and in my desperation, I thought that was the surest way to solve it), and now I have to install every app once again. But it’s okay.

To anyone having the issue… just uninstall Figma from your computer and download and install the latest version from the official website just like Josh said. It works now.

And thank you to the Figma team for solving the issue so quickly. Proud of them, and my respects to the team.

Have a good rest of the day everyone,

Cheer out.

2 Likes