Wrong resizing of absolute elements in components with autolayout

Hello :wave:

I have the following problem: I have a component with auto-layout and a text layer. In addition, I have an element that is positioned absolutely and should adjust its size when the text length changes.

Unfortunately this does not work… See screeenshot. What am I doing wrong or is this a bug?

Here how the absolute element is positioned. Maybe it’s the negative values?

Hello :wave: @Eduard4, Thank you for reaching out about auto layout and absolute position. I understand that you may find this situation a bit unusual.

I want to make sure I understand the issue correctly. Is the problem related to the difference between the left and right padding not being the same when editing the text label?

If that’s the case, could you please share your design file with us? If that’s not possible, attaching screenshots of the file with the full Figma screen visible, including the left and right panels to show the properties and layers panels, and expanding the relevant layers, would be helpful. This will help our community to attempt to replicate the issue in our own files for further investigation.

I attempted to replicate the issue, but without seeing the settings of each layer for the [Focus-Ring] component and the [bug?] component, it’s challenging to reproduce the same behavior and understand the root cause.

On a side note, I conducted some tests on my end and it appears that by setting a negative number on the X/Y for an absolute position object, you can position the object beyond the autolayout frame.

Looking forward to hearing from you soon! If I missed anything, please feel free to let us know. And if any members of our community have insights or suggestions, please join the discussion!

Thank you,