Two text fields with identical properties have different font size

Hi all,

I’ve only recently become a serious Figma user and I’m loving how easily I can create something that looks (somewhat) professional, even without any kind of design education. Currently I’m building a CV, and I’m running into what is either an extremely frustrating bug, or a misunderstanding of how Figma works from my side.

The situation is this:
Frame 1
Both of these two text fields have identical properties other than the text they contain. I have verified this by using the “Copy properties” and “Paste properties” functions. This means that both of them use the Roboto font, in Regular style, with font size 8. However, as you can see in the picture, they are not the same size. The first one is considerably larger than the second one, and I cannot for the life of me figure out why.

The issue persists when I change the font properties, and also when I copy these text fields to a different Figma file. I have also tried the commands “Recompute text layout in selection” and “Regenerate all instances (slow)”, to no avail. This seems to suggest that perhaps this is not a bug, but a feature that I’m unaware of.

Could anyone please tell me whether there is a setting somewhere that I’m not seeing which is causing this discrepancy?

Many thanks!

PS: If it’s any use, I have included an example file here for anyone to view:

It contains both the frame above and a somewhat more extensive example CV that shows how I arrived at this situation.

I looked at your file and found the reason. The text node, which appears larger, has a modified transformation matrix. Perhaps you used some kind of plugin (for example Skew) that made changes to the transformation matrix.

1 Like

I would love this transformation matrix to be a feature. Need it for responsive mobile design. How did you achieve this?

Interesting, thanks! How do I see / modify this matrix?

Something else I forgot to mention: the way I encountered this problem is by modifying a file that I created 4-5 years ago. Since all newly created text fields behave consistently, perhaps something has changed in the last years that makes the old and new fields have different display sizes?

No. Any Figma update associated with the rendering of text or other nodes does not change the transformation matrix.

Very peculiar. If I remember correctly, I started this file many years ago from a non-Figma template that I found somewhere. I haven’t used any plugins, as I wasn’t aware of the existence of plugins back then (if they existed at all). Perhaps the transformation matrices got screwed with during the import process.

Either way, I’ve fixed it now by painstakingly replacing all text fields with newly created ones. Thanks @tank666 for the investigation! Very good to know about the existence of this API and that the transformations can “secretly” mess with display sizes. I may end up writing some plugins one day. And now that this has been explicitly stated here, anyone who searches for similar issues in the future will be able to find it too!