Turning off "snap to pixel grid" should turn snapping off!


Turning off “snap to pixel grid” in a Figma Design file no longer changes snapping behavior when dragging frames around.

Whether this feature is turned on or off, a dragged frame still snaps to each pixel, no matter how zoomed-in. Note that some other objects (e.g., vector objects) still respect this setting. It’s just an issue with frames, components, and component instances. Note that If I group the frame, I then can drag the group to any sub-pixel location.

I’ve restarted my machine, restarted Figma, checked for updates, reloaded tabs, tried it in other design files. Tried it in the client, in Chrome, and in Safari. Same problem.

Can anyone else replicate this?


Yes, today I’ve came across the same issue… No matter what, objects are still snapped to the pixel grid.


same - can no longer draw vectors properly, they keep snapping to grid now


Same here :frowning:

1 Like

Yup, me too - please fix :pray:

1 Like

Same, although I found a bit of a work around, its not great, but you just have to tyope the exact decimal in the x & y positions, not great at all if you’re drawing vectors etc, but can work for frames. Sometimes.


My workaround is to group the frame I want to move on sub-pixels, move the group, and then ungroup. Still though, clearly this is a bug.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

I deselected the “Snap to pixel grid” option, and still frames snap to the pixel grid. All the other types of layer don’t, only frames. Essentially, both coordinates and dimensions of frames are not allowed to be decimal (sub-pixel), except if you change the value manually in the sidebar, but as soon as you “touch” the dimensions on the canvas, it will pop back to the nearest pixel. I’m wondering if this is a bug or not.

To me this is a problem because it generate weird behaviors, for example here in the picture, I’m trying to anchor the “Frame 2” vertex to the rectangle’s vertex, you can see the red “snap indicator” is there but the frame is not allowed to stay in between the pixels, so I cannot place it where I need it. In this specific case I could move the rectangles over the frame, but in complex design that could be not feasible. That’s why it seems weird.

By the way, does this happen to you also?
I tried different browsers and the behavior is the same for me.


When “Span to pixel grid” is disabled, frames ignore this settings when moving them on the canvas. They still snap to the pixel grid, unless a decimal value is entered manually in the inspector sidebar. Rectangles, vectors etc all respect this setting.

This seems to have been a bug for a while: see here and here

1 Like

Hey All,

We’ve confirmed with the team that certain layer types (frames/instances/components/widgets) will always snap to pixel grid no matter what, so this is an expected behavior.

We’ll update this topic into a feature request, so users can continue to share their feedback and vote for future changes.

1 Like

Thank you for confirming! Hope this can be changed to the expected behaviour in the future. Perhaps the options could be: “Snap to pixel grid”, “Only snap frames to pixel grid” and “Don’t snap to pixel grid”.

1 Like

This is recent behavior that started last October. Frames once recognized this setting. What is the rational for calling this a feature and not a bug? It’s not as if frames cannot be positioned at sub-pixel coordinates.

1 Like

Hey there,

We hear you, and while we do have a record of users who report that it stopped working last October, as of October 12th, 2022, the team confirmed that certain layer types (frames/instances/components/widgets) will always snap to pixel grid no matter what by design, going forward.

To be completely transparent, the team views this as the expected behavior. We’ll continue to pass along your feedback to the team for future consideration.

This is a problem, not a feature.
It’s a very important setting when working at pixel level (for instance when you need to export to other file formats).

I do not understand the poor decision. Why would users that explicitly turn off Snap still want stuff to snap?

Sounds like a “its a feature not a bug” moment from Figma.


We hear you @Stan5 and completely agree with and understand your frustration. Our team here can only relay the information we receive from the community to our developers and vice-versa.

With more feedback and Votes from the community, we can make a better case for this issue and force the team to reconsider the current behavior.

Maybe this usecase will help convincing the developers:
I am trying to draw a complex pictogram and need to be in full control while drawing.
While snapping to a grid is great when you are making a layout, it really sucks if you try to make a curve or the placement of an anchorpoint exactly right and the application won’t let you do it. Extremely frustrating.
I think I’ll start over in Adobe Illustrator, because I have no control in Figma and need precision.


Uff… This is a huge issue for creating illustrations and configuring logos, vector graphics, etc. Please fix this.


Hello! I’m yet another frustrated user :slight_smile:
Despite of my love for Figma, I am forced to moving back to Adobe Illustrator because of the “feature” of not being able to turn off snapping.