Turning off "snap to pixel grid" no longer turns snapping off (for frames)

Hi!

Turning off “snap to pixel grid” in a Figma Design file no longer changes snapping behavior when dragging frames around.

Whether this feature is turned on or off, a dragged frame still snaps to each pixel, no matter how zoomed-in. Note that some other objects (e.g., vector objects) still respect this setting. It’s just an issue with frames, components, and component instances. Note that If I group the frame, I then can drag the group to any sub-pixel location.

I’ve restarted my machine, restarted Figma, checked for updates, reloaded tabs, tried it in other design files. Tried it in the client, in Chrome, and in Safari. Same problem.

Can anyone else replicate this?

12 Likes

Yes, today I’ve came across the same issue… No matter what, objects are still snapped to the pixel grid.

1 Like

same - can no longer draw vectors properly, they keep snapping to grid now

2 Likes

Same here :frowning:

Yup, me too - please fix :pray:

Same, although I found a bit of a work around, its not great, but you just have to tyope the exact decimal in the x & y positions, not great at all if you’re drawing vectors etc, but can work for frames. Sometimes.

1 Like

My workaround is to group the frame I want to move on sub-pixels, move the group, and then ungroup. Still though, clearly this is a bug.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.