Switch to Enable / Disable the interactive components per instance

Hello,
I am working on a Design System and now I am adopting the interactive components. They look promising, but there is one feature that is missing.

I was so excited and started adding interactions to all the bread and butter controls - buttons, checkboxes, radio buttons, switches, lists…etc., but then I figured out that usually, the prototypes are representing a few use-cases and not all controls are clickable. So I was wondering whether there is a plan to add a switch on the component level that enables or disables the interactiveness.

2 Likes

That will be a great feature – It will be extremely helpful if we can turn OFF all interactions inside components. This way if we create a prototype we will not make users think there is any interactivity where there is none – (simple example) a button that has an overlay. But at the same time we will have one library with both interactive and non-interactive components.

2 Likes

I do agree wit this sooooo much!

1 Like

Hey guys!
There is a way to disable unwanted interactions. Simply right click the group which you want to disable the interactions for and click on “Remove interactions”.
In my case in the attached image I use this approach to remove interactions on everything that exists under the pop up that is currently on the screen.

Did you guys find a solution for this? The above mentioned “remove interactions” does not work for me when I select an instance of an element from the design system used in the file.

1 Like

Anyone else is having an issue with turning off the interactive component?
I first created an interaction inside the variants, checked them out, then cancelled my actions. But the prototype still shows an interaction.
I have restarted the prototype, and Disabled Interactive Components, but it hasn’t worked.
Screen Shot 2022-03-22 at 18.10.37
Please help!

1 Like

Aizhan -

Yep - been wondering too - checkbox you’ve identified doesn’t appear to enable/disable as expected.

However, IF you right click the instance of interactive component in Prototype tab, then you can “Remove interactions” (I’m assuming just for that instance). A quick check in prototype view showed me this functional procedure works. In my case, I am not seeing any onhover interactivity of the instance of the button that had that interactivity “removed.”

Ive just had an instance this morning where all interactive components on all my user journeys are activated. The checkbox does nothing. Something must have changed in a Figma update as I will now have to manually remove the interactions at a library level as we are demonstrating in 2 hours. There are too many screens to remove the interactions at a screen level. Has a recent update broke the “enable interactive component” checkbox?