Problems with Design Mode on Figma Slides

Is anybody else getting the following error when they try and use the design mode in Figma Slides:

Figma slides design mode requires a Figma design plan

And yes, before you ask, I am logged in on an account that has a design plan seat.

1 Like

Just to let you know if you have the same problem, the issue is caused when you create the slides in drafts rather than a team/project. If you create it in there everything works fine.

2 Likes

I was also having this issue. It automatically switched to design mode when I started manually adjusting some auto layout spacing on the slide—but now it won’t let me toggle back. I quit and reopened and it went back to slides mode but now I’m getting that design seat error again. I’ve moved it out of my drafts but that hasn’t seemed to fix it :frowning: It seems like the toggle is just buggy?

1 Like

Hi there,

Thanks for flagging. I’m checking this behavior with internal team and will get back to you once I have any updates that I can share with.

Thanks for your patience!

Toku

1 Like

Figma Slides needs a lot of work… I tried using it. It’s literally easier to design a presentation in Figma, not Slides.

3 Likes

@Paul_Boag I just experienced this issue as well but was able to fix it by duplicating the Slides file and working from the duplicate, immediately the toggle worked again. Before that I tried logging out and reinstalling Figma to clear the cache but that didn’t fix it, had to duplicate the file and then deleted the original.

1 Like

Hi all and @Ali_Doucette ,

Our apology for the confusion. Our team confirmed it was a bug and they fixed it. If you still see this issue, please feel free to let us know!

Thanks,
Toku

Awesome thank you Toku! Slides is so great, I’m a big fan!

1 Like

Still having the same issue

Can you try this?

Also please see this help center article as well:

If you have a full seat for Figma Design, you can enable design mode using the toggle in the toolbar. Design mode unlocks Figma Design features such as auto layout, the layers panel, and advanced properties, so you can dig into the details and customize slides to your exact specifications.

I hope this clarifies it!

Thanks,
Toku

1 Like

I have the same problem. I have moved my file to the team project. But it still doesn’t work and show ‘Design mode requires a Figma design plan’.

Hi there,

Do you have a full seat for Figma Design? To access Design Mode, a full seat is required:

If you have the seat but you can’t access Design Mode, could you reach out directly to the support team: https://help.figma.com/hc/en-us/requests/new? Please make sure you use the email associated with your Figma account.

Thanks!
Toku

Was just thinking the same. I actually find it nicer to just design in a regular design file, and then keep the presentation space clean and not require design mode. Other things feel weird to not include in Slide mode? Not being able to adjust the Layout Grid? Is that really a paying feature?

1 Like