In presentation view on mobile browser, tapping navigates between frames. How can I stop this?

Hi, I’ve been designing a prototype that I want to share as a presentation via link, and most people will open it on their phones.

But there’s an issue with navigating between frames. I have a very specific flow set up that requires an interaction to be performed before navigating to the next frame, and it works fine when I disable the arrow keys on my desktop. But when I open the presentation on my mobile browser, I can move through the frames by tapping on the right or left side of the screen, even though I’m not tapping a hotspot. People I’m testing it on are accidentally tapping ahead in the flow, without even realizing it.

After looking through the forum, I tried adding a bunch of new interactions to every frame, like setting keys and even click to “none”, but it still lets me tap through prototype.

Can this be disabled? The way navigating with keys on desktop can?

Hi @Sam17

It’s indeed possible
you can add this text to the very end of your sharing link: &hide-ui=1

It will disable the Figma UI, so user won’t be able to see the arrow at bottom and thus click on it

Your URL should looks something like that : https://www.figma.com/proto/...&hide-ui=1


You may also add this &disable-default-keyboard-nav=1 so it will disable the navigation key on browser (as you mentionne earlier) but :warning: be awar that mean user won’t be able to restart the prototype by hiting the R key, they’ll have to refresh the page.

In this case, your link would look like this : https://www.figma.com/proto/...&hide-ui=1&disable-default-keyboard-nav=1
Order doesn’t matter you can add the disable-default-… before the hide-ui if you want to

Hope it helped

Thank you for the suggestion! Unfortunately it did not solve the problem :frowning:

Adding the text to the end of the link did make the arrow buttons vanish as you said, but I can still tap anywhere on the left or right side of the screen to navigate to the adjacent frame.

Has this been answered yet? I’m having the exact same problem. It’s so frustrating when I’m showing people my prototype…

Hey All, sorry for the trouble!

This is a feature of the mobile app to make it easier to navigate between frames if there are not prototype flows applied.

There is also no way to disable this feature at this time, but we’ve passed this feedback onto our mobile team and you can Vote for this capability here:

1 Like

Make sure your first screen in the prototype uses a Flow starting point. That will fix it.

1 Like

Not all heroes wear capes. That solves it. Thank you :sparkles:

1 Like

Thank you! this fixed the problem