Files showing "You have unsaved changes" error since March 15th (mainly Ukrainian users)

Same problem. I can’t even open the file.

I have the issue " You have unsaved changes". I can open and sync any project but when I want to close this project, the dialogue keeps showing up. After making any changes to the project, the cloud icon and this message appear. It doesn’t matter through a browser or through a desktop application, the issue is the same.

1 Like

I am from Ukraine and started working with a colleague from another country on one project. Due to incorrect synchronization of changes in one file, I am now unable to save changes in all my files.
The only way to return the ability to edit is to work through a VPN from
USA. All other methods, including reinstalling figma, do not work.
How can I fix the error “You have unsaved changes” and work again without VPN?
Screenshot 2023-03-15 213821

Screenshot 2023-03-15 224432


I’ve also tried:

  • changing account.
  • clearing the cache, and deleting the app.
  • adding the app to exclude windows brandmower.
    Nothing helps.
1 Like

Ohh… You know… I checked with the mobile hotspot and everything works fine. I don’t use any VPN, just switch to the mobile hotspot and that’s it.
Strange things…

I let know support about it and if I’ll have some solution I resend the info to you.


Oh, it really works! But after reconnect to wi-fi i have 2 “me” person in file :sweat_smile:

1 Like

Next day, same problem. I can work or with VPN or with the mobile hotspot. Please someone fix this bug.


Добрый день) У меня проблема с сохранением изменений в Фигме. Была переустановлена десктопная версия, с закрытием всех проектов и новым входом в программу. Была попытка продолжить работу в браузере, но также выходило сообщение о не сохранении изменений. Пожалуйста, Помогите решить проблему


I am from Ukraine, and since yesterday evening I have not saved any changes either on my computer or in my browser. Reinstalling the application, checking for updates does not help!

1 Like

I had a similar problem yesterday, and it still hasn’t been resolved. I’ve tried everything, but the figma still won’t let me work. I would really like this problem solved as soon as possible, as I don’t want to switch to other platforms for work


Такая же проблема, напишите как решите проблему

vpn helps :smiling_face:

мне кажется, что проблема в интернете, подключила к мобильному - и все заработало

1 Like

I have the same thing. The changes are not saved. It’s impossible to enter the desktop version… I can only enter through the browser, but the changes are not saved…

I encountered this problem today and it turned out to be due to vpn being enabled. It took me a long time to figure out what was wrong and I completely forgot to turn it off earlier. Maybe this solution will help someone :wink:

1 Like

И у меня уже второй день проблемы с сохранением. Что теперь делать? Нужно сдавать проекты заказчикам, а я не могу ничего с ними сделать (((

problem still not gone away, figma save files only with vpn Т_Т


Hi there! Sorry to hear you are having issues! We believe that these are ISP network issues, and that Figma is particularly susceptible to these issues because we use long-lived connections. We suggest reaching out to your ISP as other customers have reported that their ISP was able to fix the problem.

Our Tech quality team has been working with engineering to address this — we’d appreciate it if anyone who is experiencing this would fill out this form so we can grab some additional data: here
To protect your privacy, please do not post any personal info in response to this.

1 Like

If this is a problem with the provider, then does anyone here have this problem and is connected to the Volia provider? Like if yes.


I have the same issue. Figma neither saves local copies to the cloud, nor opens existing projects. It started couple days ago.
If i connect mobile internet, it works.
Seems like the problem is with the wifi router, internet provider, or Figma server settings. Can anyone advise?