BUG (investigating): Rearranging order of variant properties/text styles in dropdown

When I create new variant properties, or new text styles, the newest addition will land at the bottom of the dropdown list in the right hand pane.

Is there a way to reorganise these?

You can change the order manually using drag and drop.

To change the order of the properties, select the component set, and then drag the properties you want.

To change the order of property values, hover over the desired property, when the component set is selected, click on the “Settings” icon, drag the desired values.

To change the order of the styles, deselect by pressing Esc or by clicking on an empty area of ​​the canvas, and then drag the desired styles.

@tank666 I’ve done this successfully numerous times on text styles within the panel, but there are two styles (H4, H5) that won’t let me reorder them. When I release the mouse button, they just go straight back to the bottom of the list. All the other styles can be moved around as needed just fine. Any ideas?

1 Like

You may have encountered some kind of bug. In this case, you need to contact support.

Can you share a link to an example file?

@tank666 just figured it out (kind of). Turns out it was less related to the styles I was attempting to move and more where I was trying to move them. Apparently one of the styles wouldn’t allow me to move something beside it. But by juggling the styles around with some trial and error I was able to get things set the way I wanted.

I do think it’s a bug, but it’s no longer blocking me.

Got the same bug. It’s definitely not user error. I use Figma on a daily basis since release. It even moves the style to the desired place and then moves it back a second later, lol

2 Likes

Happens for me pretty consistently still:

Jun-09-2023 15-54-07

3 Likes

Same problem for me. This used to work fine, but now it’s hit and miss.

1 Like

Same for me. It was not like that before

1 Like

Still broken. Some color styles can be dragged to a new position, others just jump back to where they were. No difference in how these styles are organized or named, it seems completely random.

1 Like

Hi all, I already discorvered this a long time ago but now I thought I have to ask. If I want to reorder styles in the list from bottom to top – it´s not possible. It always jumps back to bottom. If I do it the opposite it works, from top to bottom. But if you have lot a lot of styles it´s annoying to do so. Anyone else experienced this?

1 Like

Hey Stefan, thank you for flagging this with us. We’ve escalated this bug internally and the team is working on a fix!

1 Like

Same problem here :cry:

Hey @Joseane_Castanheira, thank you for flagging this. To be transparent, given that this is a long-standing bug and our team can not consistently reproduce this, so it will not be prioritised at this moment.
However, I’ve forwarded your feedback to the teams.

Thank you,
Gayani

I am getting the same exact problem…

Bumping this thread because the issue is still here and it’s annoying me out

1 Like

Hey @Alyssa_Maac1, sorry to hear that you’re still having trouble with this!

Tank’s solution is still correct, but let me provide some additional context from the team.

Our team confirmed that we’ll always show “Variant properties” at the top of the list and “Component properties” below. So while you can re-order within those sections, it’s not possible to re-order between the two sections.

Does this sound like it’s matching what you’re seeing?

Hi @dvaliao that’s not my issue.

It’s just reordering the text styles, sometimes it works, sometimes it doesn’t.

Here’s my issue. I cannot reorder text styles. I’ve been trying to drag it and it keeps on going back to original position.

Animation

Thanks for providing the screen recording, @Alyssa_Maac1!

I flagged this internally, and it’s actually a long standing bug our team is aware of and trying to fix. I’m going to merge a couple of threads here in the forum together then pass it along to our team for tracking purposes.

So far, we haven’t been able to consistently reproduce this bug, except for within files that users have sent us directly. If you can send over a bug report with your affected file directly to our technical quality team, it would be a great help: https://help.figma.com/hc/en-us/requests/new

Be sure to use your Figma account email, include a link to your file, and share it with support-share@figma.com, so they can take a closer look.