Figma Support Forum

Broken shortcuts for non US keyboard layouts

The keyboard shortcuts displayed in the menus and the help sections are only working if you have an American (I suppose) keyboard layout.

Where does one find the Figma keyboard shortcuts for other languages?

I am what I would call a power user, making heavy use of keyboard shortcuts. It is impeding my productivity to have to hunt for a menu item in the UI because the keyboard shortcuts are broken for me. I have a Swedish keyboard and many of the keyboard shortcuts do not work for me with no way of actually finding them.
One example: in Figma one can, or should be able to rather, hit ⌘/ to “Hide UI” but this produces nothing for me. However I recently discovered by mistake that hitting ⌘. produces that effect. :man_shrugging:

2 Likes

This might help: Toggle Show/Hide UI not working on Windows since Ctrl + \ can not be pressed - #10 by Marci

1 Like

Thanks! Doesn’t work unfortunately.
No mac shortcuts there. I tried the Windows ones on my Mac (swapping Ctrl for ⌘) but it didn’t work :confused:

1 Like

I’ve made a custom keyboard shortcut in System Preferences for that. I use “⌘+.” for this purpose. Not all shortcuts can be customized in System Preferences, though. So I echo your concern regarding bad keyboard customization and optimization for non-US layouts! I’m from Norway, and I’ve mentioned this many times in the old Spectrum forums, but nothing’s ever changed. It baffles me that I can’t customize all keyboard shortcuts in a tool that I use many hours a day!

2 Likes

There’s a feature request for this – you can upvote it: Customizable shortcuts - #12 by Chris_Vossen

Agree fully. This is embarrassing for a UX product.

/Sweden here

4 Likes

+1 /Sweden

1 Like

To hide and show UI for Mac users:

fn + Command + \

This atm hides and shows the UI for me, if that helps.

1 Like

Since I don’t have the backward slash key on my Apple Magic Keyboard it turns this into a 5-key “shortcut” so quite unpractical.

But thanks for the tip! We should gather/share these somewhere…

For the curious, this key combo does the trick on my Swedish layout keyboard:
SHIFT + Fn + Option + Command + 7

Ahhh ok. Got you. Yeah, I just realised on my separate keyboard it’s the same also. Weird, never noticed that. All the besdt :blush:

Hello, This is a big problem with Figma in Windows. There’s no way to create custom shortcuts like in Mac OS, so many of the shortcuts like Bring to Front/Back for example that would speed up work a lot can’t be used if you’re stuck with a Windows computer at work.
Are you working on a solution for this? Is there a work around to fix it?

1 Like

Thanks @Flow_Gurus,

The “Show UI” shortcuts that work for me are:
fn + + \
+ .

However the shortcut indicated in the app menu does not work:
+ \

I’m using a US keyboard layout.

I find this a little baffling…

1 Like

Try + .

The “Show UI” shortcut on macOS doesn’t even work on US keyboard layouts.

The shortcuts that work for me are:
fn + + \
+ .

I need “Bring to front”/“Bring to back”!
Working with a German Mac keyboard.