Stop figma using decimal places

Is there a way I can stop Figma from using decimal places? “Snap to pixel” grid is not fixing it. When I draw or move an object, it some times places things on the .5 pixel, a line for example, if I draw with the pen tool it will not lock to the whole integer.

1 Like

Hey there, when you enable the ‘Snap to Pixel Grid’ setting, Figma should align objects to the underlying grid when placing or moving them. This can help to prevent misaligned pixel errors.

Could you capture a video recording of the issue to give me more context? Please be sure to include the whole window, showing the properties and layers panels and relevant layers expanded.