Some components from Library suddenly lost content?

Starting this morning, I’ve encountered what I believe to be a bug in that some components suddenly aren’t rendering their content when used an a separate file from the Library itself.

For instance, our Modal looks like this in our Library:

This used to work fine, but as of this morning, when I use that same Modal in a separate file, it renders like this:

The container itself is viewable, but the contents are not. I’ve seen this happen with a few other components as well and have no clear way to resolve it.

Try to regenerate all instances in that file:

Search (Cmd/Ctrl + P) Regenerate all instances (slow) command

That didn’t fix anything, unfortunately. Tried regenerating both from the Library file and the separate file. I surely found a bug, but I’m curious why it doesn’t seem more wide-spread? Nothing about how this component is constructed is different from any other component we’ve built.

This is a very rare issue (and a fairly recent one), so not many reports can be found online. To help the team fix it you can report it to Figma support team via the bug report form with the file link and other useful information you may have.

Ok, thanks for the help!

This bug was fixed after a restart of the Figma app. Reported it anyway :slight_smile:

I’m also experiencing this issue and very concerned that there’s no follow-up to this.

Does anyone have any ideas as to:
a) what’s causing this?
b) what solutions are there for this?

Solutions I’ve tried so far:

  • Restarting the Figma app
  • Clearing the Figma app cache
  • Regenerating instances
  • Repairing selected instances

I am experiencing this bug as well, I tried to recreate the component 100 times, but always the same icon disappears. its only some content, not the whole component

Same for me :frowning: Did you manage to get it fixed?

Same bug here. Created a Side Drawer component and elements within the instance disappear.

Anyone knows how to solve this problem?


Hi, All! :wave: May I ask what is ‘Regenerate All Instance’ feature actually do to the all/selected instances?

It just refreshes their content. It is not destructive, nothing will break if you run it.

Ah I see, thank you!

This is a HUGE PAIN for us right now, can’t seem to find the issue, and we’ve tried everything

1 Like

Btw this is related to naming master components as hidden with “.” There seems to be more than 1 bug attached to instance-variants-swapping and hidden components