SOLVED: Interactive components not working

I have tried to create a simple check box to turn on / off with interactive components. However, when I add an instance to a frame to test out the checkbox is doesn’t work, even when ‘Enable interactive components’ is switched on.

If anyone could help that would be greatly appreciated!

2 Likes

Same problem here, also the Interactive components does NOT WORK within the file they were created, but curiously WORK FINE when pasted in other Figma files.
Would you kindly tell me if you eventually solve this?
Tks very much!


i cant find
Enable interactive components

I was working on the component library for my team for the past few weeks and all the interactions on the components were working perfectly until this morning I restart my laptop. All the interactive components in the prototype stop working (like button hovers, input focus, etc.).

I have tried to remove the interactions from the component and re-linked them but still not working. I’ve also removed components from the prototype and added them back again and not working as well.

I have also restarted my laptop several times and my chrome browser is up-to-date but nothing work.

I’m wondering whether if anyone else are experiencing this or similar issues?

Thanks a lot!

8 Likes

I link you to this discussion, everyone is experiencing the same problem.

3 Likes

I am experiencing the same issue

1 Like

Same issue…but not just with nested components. All interactions have stopped working.

2 Likes

And what now with figma? I have this problem too.

1 Like

Same issue here - thought I was losing my mind. All interactive components are dead. This morning all were working fine. Very relieved I am not presenting today.

1 Like

Have also restarted Figma and my Macbook multiple times to no avail. Is happening in both desktop app and browser versions. And seems to affect previously made prototypes too. Interactive components within them are not functioning.

1 Like

I’m facing the same issue here. I was trying to create a new component and nothing was working, then I’ve checked old files and were not working also.

Desktop and browser has same problem

2 Likes

I’m having the same issue

2 Likes

Same problem here. Nest interactive components not working.

Same issue. @Figma_Support My entire company can’t a prototype right in the middle of the sprint. @Figma_Support

The same problem

Looks like Figma are working on it:
https://forum.figma.com/t/interactive-components-are-not-working/28573/18

1 Like

Same issue here. I’ve spent several hours of valuable time trying to fix it.

Same here, I can’t create new component interactions. Hover states are NOT working!

Even the simplest animations do not work, where, for example, a green square does not change color to red when pressed.
As soon as the problem appeared, I asked a friend to install figma and test it. He also has such a problem.

1 Like

same problem. no interactions working.

2 Likes