Solved? - CTRL + ALT + C doesn't copy properties/style data anymore

Previously discussed in the old channel figma confuses CTRL + ALT + C - Making it function as Add/Show Comments instead of Copy Properties.
The solution I found was switching to a US Keyboard instead of an International English Keyboard →

5 Likes

It is a good temporary solution, which I am forced to use whenever this happens. Unfortunately that doesn’t solve the issue if you want to use any other layout (e.g. Hungarian). I will add some more details here, maybe it helps uncover the issue.

So for me it is not persistent, just happens occasionally. From time to time Ctrl+Alt+ keyboard shortcuts stop working on a Hungarian keyboard layout (Windows). I need to switch to an English layout where they do work - as suggested by Yuval.

After a while the issue goes away and shortcuts start working again. There is no pattern for when this happens or what triggers this and when it will return to normal. Killing apps or reboot does not help either, so please don’t suggest those as a resolution.

When Figma gets into this “bad mode”, Ctrl+Alt shortcuts act as if the modifier keys haven’t been pressed at all. Strangely enough, both modifier keys (Ctrl and Alt) do work separately, even the two together, just not together with a third button. All the more strange, as adding the Shift button as a fourth key works again:

Ctrl → OK
Alt → OK
Shift → OK
Ctrl+Alt → OK
Ctrl+V → OK
Alt+V → OK
Shift+V → OK
Ctrl+Shift+V → OK
Ctrl+Alt+V → V !!!
Ctrl+Alt+C → C !!!
Ctrl+Alt+Shift+V → OK

All other applications continue handling Ctrl+Alt+ keystrokes (e.g. Microsoft Word), just not Figma.

Killing other apps does not help, so don’t bother recommending it unless you know some specific hidden system process that causes this. Nothing helps. Not even a reboot. The problem goes away after a while on its own.

3 Likes

Not sure whether this is the same problem, but today I restarted Figma and now Ctrl+Alt+C goes to Comment mode instead of copying properties. Only workaround I know of is to use the menu, Edit > Copy properties. Quite annoying. My version is 98.14 (Windows app).

Addendum: my keyboard is ABNT2 (Brazilian Portuguese standard)

2 Likes

This works great, except now I can’t type any accents :grimacing:

Could you please recommend some Figma Course in portuguese?

Olá André,

Unfortunately I don’t know about any courses, sorry about that. I’d Google for “curso online figma português” or similar and start from there. I also suggest you start a fresh new post with this question. There are several Portuguese-speaking users in this forum, maybe they can help you better. Abraços,

Hi all,

For the technically-minded Windows users among you: I made an AHK script that goes around the Ctrl+At+C (and Ctrl+Shift+C) problems. It quickly switches to the EN-US keyboard, issues the relevant command, then goes back to PT-BR. Converting it to other languages is easy, just replace the lines commented with “; pt-BR” with your locale. Here is the code:

#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
; #Warn  ; Enable warnings to assist with detecting common errors.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetWorkingDir %A_ScriptDir%  ; Ensures a consistent starting directory.

SetTitleMatchMode, 2 ; This let's any window that partially matches the given name get activated

#IfWinActive, Figma

!^c::
	SetDefaultKeyboard(0x0409)	; english-US
	Send, {CTRLDOWN}{ALTDOWN}c{ALTUP}{CTRLUP}
	Sleep, 400
	SetDefaultKeyboard(0x0416)	; pt-BR

^+c::
	SetDefaultKeyboard(0x0409)	; english-US
	Send, {CTRLDOWN}{SHIFTDOWN}c{SHIFTUP}{CTRLUP}
	Sleep, 400
	SetDefaultKeyboard(0x0416)	; pt-BR

^+w::return

; --------------------------------------

; https://www.autohotkey.com/boards/viewtopic.php?t=19534

SetDefaultKeyboard(LocaleID){
	Global
	SPI_SETDEFAULTINPUTLANG := 0x005A
	SPIF_SENDWININICHANGE := 2
	Lan := DllCall("LoadKeyboardLayout", "Str", Format("{:08x}", LocaleID), "Int", 0)
	VarSetCapacity(Lan%LocaleID%, 4, 0)
	NumPut(LocaleID, Lan%LocaleID%)
	DllCall("SystemParametersInfo", "UInt", SPI_SETDEFAULTINPUTLANG, "UInt", 0, "UPtr", &Lan%LocaleID%, "UInt", SPIF_SENDWININICHANGE)
	WinGet, windows, List
	Loop %windows% {
		PostMessage 0x50, 0, %Lan%, , % "ahk_id " windows%A_Index%
	}
}
return

IMO it’s a dirty hack, but it’s working well so far. The ^+w::return command is used to suppress the Ctrl+Shift+W shortcut which I frequently press by mistake. Just remove / comment the respective line if you like.

Anyway, I stress again that I still hope the Figma guys take notice of this thread and fix this issue for good.

Best of luck to all.

1 Like

I even run into this issue when using a special layout that maps qwerty to ISO keyboards, which tells me this issue could be present for every other layout than US-English (non-international).

I am having the same issue today.
Changing the keyboard layout workaround works but it definitely not optimal.
It used to work well with ENG-INTL keyboard before. Switching the keyboards layout all the time is painfull.

Disabling keyboard shortcuts for language and keyboard switching seems to fix this issue.
I’ve disabled my shortcut settings in windows language settings and ctl+alt+c works again. I haven’t tested this solution in other apps but it worked for me at least in Figma.

Just enable NUMLOCK

9 Likes

MAN I LOVE YOU :heart::heart::heart:SO MUCH TROUBLE AND SUCH A SIMPLE SOLUTION XDDD
How you figure that out?

1 Like

Jesus Christ, it does work!!! NumLock needs to be enabled! Oh man, how on earth did you figure it out??? You are the MAN!!

1 Like

Probably another software is blocking the same shortcut. In my case it was Evernote. It used Ctrl+Alt+V shortcut for pasting.

2 Likes

I’m also having this issue with both the browser and Windows app version of Figma. Ctrl+Alt+C and Ctrl+Alt+V only work if I change to the English keyboard layout.

What about those who don’t have NumLock? Unfortunately I don’t have one on my laptop.

I still think that CTRL+ALT+C should invoke “Copy Properties” instead of “Comments” regardless if the following are on or off:

  • EN-INTL vs EN-US Keyboards
  • Num Lock State

The bug started when they double-mapped Ctrl+Alt+C to “Comments Mode”, Not knowing that the keyboard shortcut is already assigned to “Copy Properties” as shown here for many years already:

image

2 Likes

Hello. One good developer BladeMight just responded to my suggestion and offered his own workaround for INTL layouts (the best and trouble-free in my opinion) with Mahou app: at the time of typing Ctrl+Alt+ combinations, the keyboard layout will temporarily change to special one where the symbol mode doesn’t involve duplicating AltGr to Ctrl+Alt.

Just open Mahou “Layouts” tab and enter in “Temporary change layout on LCtrl+LAlt combination” field: 67699721 (English US code), then click on “Apply” button.

You can freely specify any other (desired) keyboard layout (without AltGr) code for a temporary change (but it made no difference).

Download (x64): https://github.com/BladeMight/Mahou/releases/download/latest-commit/Release_x64.zip

Other builds: Release latest commit release ([417879a] build #1242) · BladeMight/Mahou · GitHub

Here are my settings: https://i.imgur.com/Auh6xHu.png

1 Like

So… still no official fix for this? I sent a support ticket a while ago and the only thing they responded to me was that was basically a one-off bug. Thought it was just me.

What would be solution for those who don’t have numlock on their keyboards and don’t have the language bar available (even if I had, my keyboard is ABNT2 (PT-BR Keyboard))?

I’m aware of @Rubem_Pechansky 's script solution but I’m not familiar enough with scripts to install it and would preffer avoid using if possible since it could lead to several other unforeseen complications.

Hi everyone,
TL;DR: if keyboard changes aren’t working for you and you have Loom installed, quit Loom.

Long story: I found this forum because I was facing the same issue. I tried the keyboard changes and it didn’t work. Then I googled the shortcut for confetti to make sure my switches weren’t causing an issue (i have a mech keyboard) and found this: Did I just find an easter egg in Figma? · Figma

Sadly this is an issue if you run Loom and Figma together -_-

Posting this here in case it helps anyone!

Same here. I discovered that Loom was causing the problem by closing tray applications one by one until the Ctrl + Alt +C shortcut worked. Then I checked Loom preferences and found the shortcut conflict.

1 Like