Prototypes don't work on iPads

I’m building a very simple prototype to run a tiny user test. The prototype has 1 single flow, 1 page with a scrolling effect, and the rest of the pages use “on click” > “navigate to” > “artboard X” with a basic “instant” animation.

The prototype works perfectly fine on mobile and desktop, but on iPad (both via the Figma app and via a browser such as Safari, Mozilla, and Duckduckgo) everything is broken.

  1. I have a vertical scrolling container with 4 cards inside. Each card links to a different page. If I touch the screen to scroll, but my finger touches one of the cards, I’m automatically redirected to the card’s link. So, it looks like 2 interactions cannot happen on the same area of the screen. This doesn’t happen on desktop and mobile.

  2. Any other elements outside the scrolling frame (within the same artboard) lose their interactions. I have set a simple top right button that I keep on clicking, but it simply doesn’t work. I’ve realized this is because, as I said before, different interactions on the same screen are super conflicting, but if I, for instance, place the button where the scrolling area lives, then it seems it works.

  3. I tried using smart animate, but the animations are a no-go on iPad. It doesn’t matter how I interact with the screen, the overlay won’t open.

  4. There are elements that are simply impossible to predict, I created top tab navigation and each tab is clickable except for one. I have revised a thousand times that all the connections are correct, that I do not have other interactions happening on the same screen, and I have also re-done the entire prototype from scratch. It still doesn’t work… and it’s just a “click here and take me there instantly” move. The app is very unpredictable.

I’ve used two different iPads: iPadOS15.4.1 and iPadOS12. Both operating systems and devices give me the exact same bugs. I’d be happy to do a demo with a team member from Figma so you can see how I set up my file, and how buggy it all is on these devices. I hope there’s a fix for this. Thank you.

3 Likes

The same thing happens with me! Although there is a new UI and features like FigJam on iPad, on my iPad mini (2021) everything “double clicks.” Instead of clicking once, my clicks register twice which messes up every function of my prototype. I hope they fix this ASAP because it has been 6 months!

2 Likes

Experiencing very similar issues.

And I’m only using very simple interactions in the prototype:

Click—>navigate to---->
Click----->open overlay
Click------->close overlay

2 Likes

Thank you for sharing your experiences, it’s good to see I’m not the only one who has so many issues with such basic interactions.

I am dealing with the same issue. This will make it impossible to demo with client on my iPad pro 12.9. Every time I click to open a menu it’s like it double click to immediately close that menu. PLEASE fix this ASAP!!! I just went through all of the trouble of re-designing and re-prototyping my entire project that I had previously created in Adobe XD. Am I seriously going to have to go back? Come on Figma!!!

1 Like

If I’m reading your issue correctly, it sounds like a problem I had with my prototypes working on an iPad. I had no problems with touch on surface pro or mobile phone, just the iPad. If you have a clickable item that opens an overlay or swaps one screen for another with the hotspot in the same place, the same issue happens for me. I switched the action to “mouse up” which allows you to add a small delay in the action taking place. I used 250ms and it solved my issue. I uploaded a screen grab of one of the menu actions this technique fixed within a table row for me.


1 Like

Thanks Brett, this totally fixed the issue for me! I didn’t want the extra delay though, so I changed it to 1ms instead of 250ms and that did the trick. Looks like Figma wins again!

Much appreciated. Switching to “on Mouse up” addressed the issue I had with my overlays