"Fixed stay in place" is disabled in Figma

Hello! I’m trying to:

  1. make the screen scrollable vertically; and
  2. make the iPhone status bar and “scroll to top” arrow fixed stay in place

I’ve managed to make the screen scrollable vertically, however, I’m having a hard time making the iPhone status bar and “scroll to top” arrow to be fixed. The “fixed stay in place” is disabled on my end.

Please help me. I’m getting frustrated and can’t wrap my head about this :frowning:

1 Like
4 Likes

mine still doesn’t work. it’s quite frustrating

Sorry to hear that, @Amanda_Ovando!

Are you able to share a screenshot, screen recording, or the link to your file, so we can take a closer look?

Also had the disabled Prototype option “Fixed (stay in play)”

Took a couple of hours or less, figured out besides the other recommendations. The base frame cannot use "Auto Layout.
Once you shut that off select the frame you want to “no scrolling” and go to the prototype settings and the “Fixed” option is now available

I have both a header & footer fixed, with content scrolling the middle.

Tom

4 Likes


This image shows another detail.

The fixed objects need to be outside of the main content, also the footer must come first, followed by the main-header, then inside is a header and subheader row.

How this helps.

I created a demo-fig file, but since I a “newbie” I am not allowed to upload/add attachments.

Tom

1 Like

Thanks for the screenshot. It’s hard to be sure what’s happening though. Please reach out to the support team directly via this form for help: https://help.figma.com/hc/en-us/requests/new

Be sure to use your Figma account email, include a link to the file, and share it with support-share@figma.com, so they can take a closer look.

In the base frame, set the Scroll Behavior / Overflow to “Vertical”.

1 Like

image

Fixed is disabled?

Fix while scroll was easy to use. Why to complicate simple functions?

1 Like

Hi I figured out why Fixed is Disabled in Figma.

  1. First, make sure your frame is not under another frame. It should be on its own.

It should look like this in the layers:
image

Then in Prototype > Scroll Behavior > Position Fixed can now be selected

3 Likes

Hello, I also had the same issue and JUST FIGURED IT OUT RN IM SO HAPPY!
So I the fixed position wasnt letting me click it and i realized it was because the frame that I wanted to make fixed was clipped inside another frame other than the parent frame. when I pulled it out of the other frame and just left the layer under the parent frame, it immediately let me choose the fixed position!!! I just won in life muahahahahah:)

1 Like

I Tried all the methods in this topic, this is the that really works

It works for mine as well! Thanks a lot! :blush:

1 Like