Everything is underlined in red when I type in Spanish

If there is already a way to either turn off spellcheck, or to tell a FigJam file that I am working in a different language, or if that could be introduced, that would be great. I’m a new user and a Spanish teacher, and I am loving starting to use FigJam in my classroom, but it’s a bummer that most words are underlined in red!

1 Like

Hey there, so sorry for the frustration!

You can enable or disable spell check from the Main Menu:

  1. Click on the Figma icon in the upper left-hand corner
  2. Go to Text > Spell check
  3. Click Check spelling to enable or disable spell check

You can also change your preferred spell check language from the Main Menu:

  1. Click on the Figma icon in the upper left-hand corner
  2. Go to Text > Spell check
  3. Select from the list of available languages
2 Likes

@dvaliao Norwegian language is not in the list, only English. How can I add Norwegian spell checking?

Hey @Steven6, sorry for the trouble!

I just checked in the desktop app and in browser, and Norwegian should be available by following the same instructions above:

Can you please confirm whether you’re accessing Figma via web or using the desktop app?

If you’re using the desktop app, this is probably due to Norwegian not being available on your operating system. Perhaps you could take a look at the languages available on your device, just to be sure?

Can you also please confirm which operating system you’re using?

Depending on your operating system:

  • On Mac: Figma auto-detects and uses your system’s preferred language for spell check
  • On Windows: If you don’t see the language you want to use, you may need to install a language pack (more detailed instructions on that here)

Hi @dvaliao
So I’ve checked and my machine have the language pack for Norwegian, and Win 11 uses Norwegian. My browser also uses Norwegian. Still, English is the only language showing up in my selection (see screenshot)

1 Like

Thanks for the additional information!

Have you checked your Account’s Language under the main menu: Settings > Language > Change language?

After checking your Language under Settings, since it also sound like you’re using Figma in the browser, can you try clearing your browser cache to see if that helps at all?

Hi! I have the same problem and symptoms as @Steven6. When I follow your suggestion as of April 3, I only get the options for English and Japanese, see below.
image
So I would like to repeat the original question:
How do I add languages to the list of available spell check languages? (referring to the list you showed in your answer from Mars 21). :slightly_smiling_face:

Hi @Bjorn_Larsson

Figma support told me that I need to download and install Basic Typing.
This is installed at home so everything works. But as you can see, it’s not installed on my work computer. I’m in the process with IT to see if I can get it installed.

You will find it under language options.

image