Custom keyboard shortcuts in native app are not working. (Zoom to fit, zoom to selection)

Hi, I tried adding my first two custom app keyboard shortcuts in the native app on Mac.

Neither one of them work.

I changed…
“Zoom to Fit” from SHIFT + 1 to CMD + 1.
“Zoom to Selection” from SHIFT + 2 to CMD + 2

Neither one of these work, even though in the view menu it shows the shortcuts as CMD + 1 and CMD + 2 now.

This is stupid… Every other app uses CMD for the shortcuts in view/zoom, whether that is Photoshop, Sketch, whatever… not SHIFT. I get that the web browser has those shortcuts reserved to jump to the first and second tab, but I’m doing this in the NATIVE Figma app.

Can somebody advise of what to do in order to get this shortcut to work… I don’t see any reserved shortcut for CMD + 2 in the app, and for CMD + 1, it automatically takes you to the home tab. (ahh… i see now, it’s treating the tabs in native Figma now as if they are browser tabs)

I’m jumping in and out of zooming to selections more often than I am switching between tabs, also in which case, I can navigate tabs fine by holding CMD + OPTION and LEFT/RIGHT go go between tabs, or by using CONTROL + TAB.

How do you get custom shortcuts to work?

Hi there!

I totally get your frustration—keyboard shortcuts are essential for a smooth workflow! Here are few steps you can take to sort this out.

  1. Check for Conflicts: It seems like CMD + 1 and CMD + 2 are reserved for switching tabs in Figma, even in the native app. You might need to choose different shortcuts to avoid conflicts with these built-in commands.

  2. System Preferences Workaround:

  • Open System Preferences > Keyboard > Shortcuts > App Shortcuts.
  • Click the + button, select Figma, and add your custom shortcuts there.
  • Enter the exact menu title and your desired shortcut. This can sometimes override the app’s default settings and might help in this case.
  1. Figma Preferences:
  • Go to Figma’s Preferences (under the Figma menu) and see if there are any options for managing or resetting shortcuts.
  1. Alternative Shortcuts:
  • Since CMD + 1 and CMD + 2 are conflicting, you could try CMD + SHIFT + 1 or CMD + SHIFT + 2 instead. These might not interfere with the default tab navigation shortcuts.
  1. Feedback to Figma:
  • If nothing works, it might be worth submitting feedback to Figma. They are quite responsive, and your input could help improve the app for everyone.

I hope one of these solutions helps!

I’ve already filed a bug report/feedback with Figma, but they take a long time to respond, or not at all.

I don’t understand why you can’t assign your own shortcuts for the “native” app. I don’t need 3 different ways to navigate to their home button and tabs. CMD + 1 and CMD + 2 should be do-able, rather than shift.

SHIFT just doesn’t make sense for zooming from an ergonomic perspective, your thumb is near the CMD key, not the SHIFT key.