Can't find the "flow" button on the right hand side bar

Hi, I’m having a difficult time with my second project on Figma. I’m unable to create a flow on my responsive website design. I’ve tried duplicating the project/copy and pasting it to a new layer, and even tried to start building it from scratch again, but nothing is working. I’ve reached out to the support team twice but haven’t gotten a response yet. Can anyone help me?!

Hey @Reem_Shalhoub, sorry to hear you’re having trouble creating a flow for your prototype!

When trying to create a flow starting point, can you please confirm if you’ve done the following?

  1. Ensure you’re in the Prototype tab
  2. Select your starting frame on the canvas

If you’ve done those two steps, you should see a Flow starting point option.

Hi @dvaliao, thank you so much for your response. Unfortunately, I have ensured that i’m in prototype tab and did select the starting frame on the canvas but nothing is working. I’ve tried duplicating the project, as well as creating a new one. I have no idea what to do and Figma customer service has yet to respond to any of my emails. If you think of anything else I could try, I would really appreciate your help!

Hey @Reem_Shalhoub, sorry to hear this!

Are you able to share a link to your file with us here on the forum?

If so, please include a link to your file and share edit access with support-share@figma.com, so we can take a closer look.

sure! here is the link:

I shared edit access. thank you so much! I look forward to hearing back from you and please let me know if you have any further questions.

Hi @dvaliao, any updates on my issue?

Hey @Reem_Shalhoub, sorry for the delayed reply!

I was out of the office for the July 4th holiday.

From what I can see, it’s only possible to make the designs on this page into a prototype by using the new AI beta to make prototype. Is that also the case for you?

Are you using the previous UI or are you on the new UI3 beta?

@dvaliao thank you so much for your response. To be honest, I have no idea what the new AI beta is, nor how to locate/use it. Can you please help me out by demonstrating where I can turn this mode on? (if that’s how to approach it)

Thanks for the additional context, @Reem_Shalhoub!

Since you don’t have access yet, it’s likely not the issue.

From what our team can see, your issue happening because your design is not within a frame. You can’t have an interaction coming out of a group, nor can you set them as a flow starting point.

You can only add a flow, if your design is inside a non-group or non-section top level frame. If you put your layers within a frame (and give the layers more descriptive names rather than the default names), Flow should start working as expected.

Thank you so much for your feedback, @dvaliao. I apologize about the late reply! I understand what you are saying, however, I am not quite sure how to put the layers into a non-group or non-section frame. Do I need to ungroup all of the layers? Is there a step by step guide on how to do this? Can someone please demonstrate, if possible?