Auto layout stopped working?

Hi guys,
I have a problem with Auto Layout, it stopped working the way it used to.
For example, these are the steps I always use when creating an auto layout frame, but it doesn’t work any more, except for when the element inside the frame is text.

  1. Create a rectange (this will become the frame)
  2. Create the element inside (it can be a text field or any other element)
  3. Place the element inside the rectangle
  4. Select both the rectangle created at #1 and the element placed inside the rectangle and hit Auto Layout
  5. RESULT: if the element is a text field, it works fine, just like it used to. If the element is anytning other than a text field, it doesn’t work. Basically the rectangle turns into a frame, as expected, Auto Layout is turned on, but in reality it doesn’t do anything, it behaves simply as a frame without Auto Layout.

Please check out this video I made, the example with the text is exactly how it should work and used to work.

Is this a bug?

Thjank you,
Chris

1 Like

in reality, the upper rectangle is positioned absolutely inside the created auto layout, so I think this is not a bug but a feature :rofl:

Hi @apretov
What do you mean the upper rectangle is positioned absolutely inside the created auto layout? I’m not sure I follow.

The thing is, in the very recent past, the way the auto layout behaved in the text field example in the video, used to be the same for anything else, like components, shapes, other frames etc. Now it’s just the text. The way the text example works is the auto layout turns the rectangle into a a frame, giving it paddings. In the other two examples, the rectangle remains a rectangle, even though the exact same steps are taken.

1 Like

idk why with text object rectangle is converts to frame, aboslute position is more logical behavior since it was added (when you place one object on another)

@apretov
It was a suddon change, I was simply used to another way. I was also used to automatically converting a rectangle to a frame when enabling auto layout, it doesn’t happen any more, the behavior simply changed drastically :slight_smile:

Just now I faced the same issue, then came across this thread, so I am not alone.

I wanted to create a button, here are steps that I took

  1. Selected a text and an icon, hit the auto layout, frame text+icon got created.
  2. Created a rectangle of desired size
  3. Put the text+ icon frame over the rectangle
  4. selected the rectangle and text+icon frame
  5. Hit the auto layout button

What I expected was a button will be created with auto layout, and there I can adjust the vertical and horizontal spacings inside the button. (This used to happen earlier and that was way more convinient)

But now the text+icon frame is positioned absolutely

I need to manage the vertical and horizontal spacing manually, and yes when you scale the frame this absolutely positioned inner frame will not follow the outer frame’s scaling aspects.

But surprisingly the earlier function still works the same if are putting just the text and creating an auto layout

I feel earlier way was more convenient

1 Like

@nandanwarnikhil97
So I’m not insane, they did change the way it works :smiley:

1 Like

So how does it work now?

Basically, if you would have a rectangle and above it some any other elements (paths, text etc.), if you would hit the Auto Layout button, that rectangle would become the frame in which all those elements would stay.

wow. i was not the only one who think this s very uncomforable. i can’t understand why they changed this. why???

We use auto layout more than absolute posititon!! they should provide setting option about this.

3 Likes

It does feel pretty weird, especially since we were all used to having a rectangle turn into the frame when adding auto layout. We were also used to everything positioning based on the auto layout. It works strange now, but I did get used to it, but the previous way was better and smarter imo.

Yes only works for text for me. Was watching a Figma tutorial that’s a year old and was about to pull my hair out as I couldn’t get some shapes to be properly auto layout’d like they were being in the video. Only text works for some dumb reason. Glad I’m not alone i suppose hahah

1 Like

@Max_Nicholson I think they fixed it / changed it back to how it was? Or did I jsut get used to it? :smiley:

I think it is still doing it, I’ve just started remove absolute positioning everytime it doesn’t work - I wish we could decide the default for ourselves because this is so annoying

I got the exact same problem when I was watching a tutorial and I got it worked out after reading this thread. I had to select all the components within the Frame (note the Frame is not included), then select “absolute position”, then select “constrain proportions”. After this, all of sudden everything is auto-laid-out. Just out of curiosity, I then deselect both “absolute position” and “constrain proportions”. Somehow it continues to work. I’m getting very confused with this. I think there is a bug or some weird things going on there.