Vertical gap between items - auto layout

Hello everyone,

I am following the beginners list from YouTube and I am on Figma For Beginners: Create designs (2/4). At the time stamp 12:15 the auto layout of my “Feed” frame is not adjusting the vertical gap as it should.

As I am a new user I can’t upload photos so maybe a link to my project will help ?

https://www.figma.com/file/bQCnjxEJgTaaSOzzwhAFiw/Bart-Wireframe-Lo-Fi?type=design&node-id=58%3A1010&mode=design&t=tCX56LJ562K2mvbE-1

As you can see the text goes onto the next item in the deed even thou the setting for the gap is on and at 8.

I am pretty sure I have followed the instructions in the video to a T and yet there is a mistake somewhere. What could possibly be the issue ?

Many thanks.

Hi, Bart4.

After checking your file, I’ve determined the issues on your file.

Here are the steps to adjust the auto-layout frame you created:

  1. Remove the absolute position of the 3 Post instances in your file.


    image

  2. Set the auto-layout frame Feed’s height to hug.
    image

  3. Set all the Post instances height to hug.
    image

After doing that, the auto layout frame should work.

1 Like

Hello @Raphael_M,

Thank you for taking the time and looking into this. With your instructions I was able to fix the issue, worked like a charm.

Many thanks.

1 Like

Happy to help :smile:

1 Like