Signing Up for Education Plan "Missing School Type"

Hello! I am trying to sign up for the education plan, but evetime I try it tells me I am “Missing School Type”. It seems I have filled out all of the available boxes given. What do I do from here? For reference, my school is listed on there and I have selected it in the school box.

1 Like

Hey Nancy! I’m going through this problem right now with a class I am TA’ing for. It seems like in our class this issue was caused by an old URL. Use this link: Figma for Education | Free Tools for the Classroom, scroll down to the button that says “Get verified”, and go through the process again. You could also search “Figma education” and click on the first result that pops up. Hope this helps!

Same for me. To me this seems to be a bug. The URL is

1 Like

I am having the same problem, and this didn’t work. I am trying to get Figma for education for the coursera google course



I’d like to bring to your attention that the same issue is presently impacting my students in class, preventing them from verifying their status.

Here is a detailed replication of the problem:

  1. Visit
  2. Complete the provided form
  3. Click on the submit button
  4. Unfortunately, progress is halted due to an error message stating: “Missing school type” (screenshot attached)

Interestingly, the form does not feature a field to input the school type, leaving me uncertain about the necessary steps to take.

Thank you for your efforts in investigating this matter.

figma students

1 Like

Hey All, thank you for flagging this issue!

This seems to be a trending issue. We’ll pass this along to the team to investigate.

As a workaround, can you please try clearing your browser cache or desktop app cache or an incognito window to see if that helps?

Here’s how to clear the desktop app cache on a Mac:

Quit the Figma desktop app
Open and enter the following command: rm -rf “$HOME/Library/Application Support/Figma/”{Desktop,DesktopProfile}
Try opening the desktop app again

Here’s how to clear the desktop app cache on Windows:

Close the Figma desktop app
Open the Start menu, and paste in this, followed by entering: %APPDATA%\Figma
In the window that opens, delete the Desktop and DesktopProfile folders if they exist
Launch the desktop app again

Here’s how to clear the cache on Chrome:

  1. On your computer, open Chrome.
  2. At the top right, click More.
  3. Click More tools Clear browsing data.
  4. At the top, choose a time range. To delete everything, select All time.
  5. Next to “Cookies and other site data” and “Cached images and files,” check the boxes.
  6. Click Clear data.

Hi, I am having the same issue when applying for Figma Education plan. I’ve tried the steps to clear desktop app cache on Windows and Chrome and still not able to apply.

1 Like

Hi same issue here from Singapore.

I am experiencing the same issue from Germany.

Hi, I am having the same issue here

Me too, having the same issue.

Not working for me as well :frowning:

Neither clearing the cache nor using an incognito window helps :frowning:

Hello, I am having the same issue here

Same issue here. POST 400

So, i managed to send the school type information via a proxy, but now the form complaints about another missing field. See the attached screenshot (irrelevant information is pixelated).

Done: After I found the missing variable in the corresponding JS and sent it via proxy, it worked.

I assume that’s not the intended way, though. Or is this an elaborate CAPTCHA? :slight_smile: :grinning:

Hi all,
Thank you all for your help here by reporting this!

To give you an update, our engineering team is currently investigating the issue - while I cannot set an ETA yet for the fix at this time.
Thanks for your patience in the meantime, we will keep you updated here soon :pray:

1 Like

Hi there, we’re having the same issue for the class that I teach. Hopefully, ya’ll get it solved soon! Thanks!