Invalid video was removed

I got my education plan and when I am trying to upload a video, it’s showing “Invalid video was removed” again and again. I tried other videos and used different devices also it’s showing the same problem. Please help me with this problem


Sorry to hear you’re having trouble trying to upload a video!

Can you confirm if this happens in the desktop app and/or browser? Has this happened on any other files?

If the issue is present on both, can you try clearing your cache and see if that helps?

You can clear the desktop app cache on Windows under the toggle-arrow at the right of the top toolbar under Help > Troubleshooting. If you’d prefer to manually clear your cache you can:

  1. Close the Figma desktop app
  2. Open the Start menu, and paste in this, followed by enter: %APPDATA%\Figma
  3. In the window that opens, delete the Desktop and DesktopProfile folders if they exist
  4. Launch the desktop app again

You can clear the desktop app cache on a Mac in the Help menu under Troubleshooting. If you’d prefer to manually clear your cache you can:

  1. Quit the Figma desktop app
  2. Open and enter the following command: rm -rf "$HOME/Library/Application Support/Figma"
  3. Try opening the desktop app again

I just subscribed and was creating my first project that needs to have a video and it is not letting me. When I import, the image appears for 3 seconds and then it disappears and a message at the bottom appears saying "“Invalid video was removed”. I have done what @dvaliao have suggested but still nothing works. I have used the website AND the desktop version on my mac and both dont work. Could you please help or fix this?
Many thanks

Hey @John_Lee,

Sorry to hear you’re still having issues after trying the workaround above. Our support team should be able to look into potential issues with the video. Please reach out via this form for help:

@John_Lee @ADITYA_RUHELA try converting or compress the video trough a converter like or Adobe Encoder and convert it to a standard H264 codec of one of the presets (Fast 1080p30p) that worked for me.

I had the same issue, and I tried many different things (including H264 codec), but the only solution that worked on my end was converting to the webm video format which you can make it easily over here: Online MP4 to WebM Converter - Convert MP4 to WebM and Other Formats to MP4 hope that helps.

Bro this is not helping I try all solutions :expressionless: