Pinch-to-zoom unreliable

Fortunately I’ve never had this happen on MacOS.

The Windows bug for pinch zoom however was 100% terrible all the time.

Same here, very frustrating!

1 Like

I’ve been having this same issue for a few weeks now. Unlike some people, the issue was universal for me. Once I opened Figma and the bug occurred, I couldn’t zoom on browser, adobe apps, etc. I also had the bug happen when in Miro when Figma wasn’t even open, so I have a feeling it’s not a Figma specific issue for me, like Joe said.

I’m on a MBP and my quick solution has been to just close my computer and open it back up quick. Fixes it for me, but is a hassle.

Same problem here :confused:

1 Like

Thanks Joey! Your advice helped to solve my issue also:)

Same same. Apple Macbook Pro 2021 M1 … Pinch to Zoom not working multiple times a day. Hella frustrating ;/

Hi @Josh. It’s been a few months since you promised to bring this up with the Figma engineers and report back. Could the dev team provide a deadline when we’ll see a fix for this bug? As 100+ people have commented, it’s not a MacOS-wide bug and it’s very disruptive to our work in Figma. Thanks!

3 Likes

Whenever this happens to me, I press the - or + buttons on the keyboard and it seems to ‘re-activate’ pinch to zoom.

Hope this works for ya’ll.

2 Likes

Tried all the tips in this thread, and this tip of putting my mac in sleep mode (to my surprise!) was the only thing that worked. Thanks for sharing it!

I have just started doing UX design so I have just installed the Figma app on a brand new 2021 MacBook Pro and I am having this same issue. I have to shut my entire laptop down to get it to function normally again. This is one of the worst bugs I have ever encountered while using a design software. And I am using the paid version of Figma… if you don’t fix it soon Figma I’m going to invoice you for my time you have wasted…

testing babab

Adding a +1 to this.

PMs at Figma, please fix this! This is so frustrating!

1 Like

+1 please fix this — happening more and more (m1 MacBook Air).

1 Like

I have also been experiencing this issue and it’s the most frustrating thing.
My quick fix is to sleep my MacBook and wake it.
Please please please fix this!

As someone who does zoom in & out literally every few seconds, this bug is very frustrating.

I’m quite sure at this point, this is caused by figma app. I experienced this on Mac OS Monterey, zoom in & out works fine in other apps until I switch back to figma, then zoom become unreliable.

Just a few days ago, I upgraded the OS, giving the new Mac OS Ventura a try. Everything works well, no problem zooming in or out in ALL apps, until Figma was opened (while running web browser etc in the background) then it did happen again, screwing pinch-to-zoom.
Until today, this has been bugging me daily.

I’m running Figma on M1 imac.
I tried all the workaround mentioned above:
a. quickly turn off/turn on trackpad (if you are on macbook, you can’t do this)
b. put mac to sleep and wake it up (sometimes doesn’t work)
c. go to preference, turn off pinch-to-zoom, then turn it back on again (works, but too much hassle. You don’t want to do this several times daily)
d. close Figma then open again. Absolutely works, if you have all the time in the world.
e. Also, I tried open a new figma window (separate file). Sometimes only one window with pinch-to-zoom works, the other figma window’s zoom just freeze.

my best workaround so far:
just use alternate keyboard shortcut command + two finger swipe up/down instead of pinch-to-zoom.

This is by far the most efficient workaround, But this gonna screw your muscle memory if you use pinch-to-zoom in most apps.

I hope this will be fixed soon. Looking at this thread, it was started in January and is already mid-year now. I have really low expectations it’s gonna fixed soon.
Would very much appreciate it if this bug could be prioritised @Josh

Please understand that most of us designers here use Figma on daily basis. This bug is such a time-waster.

2 Likes

This went away when I tried a previous suggestion, turning off pinch to zoom in my System Preferences, and turning it back on again. Now the solution does not work. This has been going on for a while, I hope it gets updated soon - it’s so frustrating.

I’ve tried a few things before none of which worked consistently.

M1 MacBook Air.

I tried something new and it instantly fixed it: Quit all other apps.

I had messages, whatsapp, and chrome open at the time. Pinch worked in chrome just fine. The moment I killed them the problem was fixed. I re-opened the apps and pinch is still working in figma.

@Josh I find that the pinch-zoom bug seems to (inconsistently) trigger when I use the macOS 3 finger swipe to show my open windows (“Mission Control”) and then tap to select Figma. Food for thought for the team to debug with.

my fellow frustrated designers,
instead of using pinch to zoom, try command key + two-finger swipe up/down while pinch-to-zoom not working …

after a few minutes, when the bug “automatically fixes itself”… then go ahead with your pinch-to-zoom again

If you do it that way, you don’t need to put your mac to sleep or kill anything lol

7 Likes