Memory full

Got a pop-up saying 100% memory reached on one figma project. Can I add more files (not pages in the same file) to the same project? How do I proceed? FYI it’s not a paid subscription.

Thanks in advance

Hey there @Nikhil_R_Sannagoudar. Here’s our help article that talks more about memory usage in Figma.

If it’s at 100% you’ll need to use version history to revert to an older version and then start breaking up the file.

For a paid subscription, say for professional, it says ‘unlimited version history’. So, does that mean we can add as many pages in the same file?

I feel like this is the same problem I am having for two days now. Tech support is not very helpful: slow to respond, not reading my message really, pasting content from the help page. Very disappointing btw.

Not a problem of an account type (I’m on “Professional”) and I hate feedback like “It’s your fault, here’s how you should work with memory limits”.

Pasting my correspondence:

  • My file went from being OK to 100% memory used overnight, when I was asleep (last night).
  • Reverting through the Version history DOES NOT WORK - same error screen.
  • The memory issue vanished magically, but it reverted to some old version from, maybe 3 weeks ago, with no way to bring back a later version (because it DOES NOT WORK)

I did an experiment (latest Chrome browser).

Using the same file that restored itself to a version from who-knows-when:

  1. I’ve drawn a yellow rectangle
  2. Saved changes to version history
  3. Tried restoring a version autosaved minutes earlier
  4. Got a red screen of death
  5. From there tried restoring the saved yellow rectangle
  6. Got a red screen of death again
  7. Closed the browser tab. Reopened Figma and the file.
  8. File opened with the yellow rectangle in its place
  9. So I’ve changed the rectangle to purple and tried restoring to the saved “yellow” version again.
  10. Got a red screen of death
  11. Closed the browser tab. Reopened Figma and the file.
  12. File opened with the purple rectangle in its place.

Is the version history broken for me?

And now it happened on an entirely different file, which isn’t even that layer-heavy!
I was using Find and Replace plugin to change text. This usually takes long minutes, even when changing only a handful of layers, but never crashed the file!

What’s going on?!

There were other threads regarding this problem on this forum, so I know others have this issue.
We’re a paid customer and we’ve just lost ~3 weeks of work, plus can’t really proceed until this is fixed.

Maybe @Josh will be able to for-real-help?

#100% of memory used #version history #crashing #restore doesn’t work #problem


This topic was automatically closed after 30 days. New replies are no longer allowed.