Flattening multi-layer icons won't allow for color changes

Hi there,

I’m bringing some SVG icons in my library as they come from the Material Icons font page. Some icons are built with grouped layers instead of having one vector path. (Making swapping icons painful)

So, I went ahead and flattened (Cmd + E) all the shapes into one and exported the library. Once published and brought into another project, selecting some icons completely ignore any color changes. Is there anything Im doing wrong on my end?

Thank you.

1 Like

I have this same issue too and can’t figure out how to resolve it.

1 Like

Ok, found a “fix” for this: removing and re-applying the color fill after flattening the shapes seems to be working for me.

This is still definitely a bug but… it at least works.

2 Likes

That worked! It was driving me crazy because I had about 20 variants of my logo in different brand colors, which all worked a few days ago, and stopped working yesterday. I was able to change them all back individually based on what you said to do. Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.