Figma Support Forum

Some shortcuts not working on non-us keyboards

  1. Describe the bug/issue you’re running into?
    Shortcuts partially do not work with non-US keyboard, e.g. Pressing “/” to start cursor chat doesn’t do anything on a German Mac keyboard ("/" is not left to the left shift key but secondary function of the “7” key, so you need to press Shift + 7 to Enter a “/”)

  2. Are you able to consistently reproduce it? If so what are the steps?
    Yes.
    Steps: Press Shift + 7 results in nothing.
    Alternatively pressing the key next to the left shift key (where “/” is located on an US keyboard layout) will Zoom out as it is the German “-” key.

Personal sidenote
To fix this it would be really great to be able to customize ANY keyboard shortcut (also for Figma itself. Some shortcuts might work on US keyboard layouts but for others it’s a real pain).

  1. Share a screenshot, recording, console log, link to the file, etc.
    Not possible / necessary

  2. Is the issue only happening in desktop app or a specific browser , or both?
    Browser:
    Brave Browser
    Version 1.22.71 Chromium: 89.0.4389.114 (Official Build) (x86_64)

Desktop not testet yet (if Figmajam is even supported yet on Desktop?)

  1. What OS/version and/or browser/version are you using?
    MacOS 11.0.1
    Brave Browser
    Version 1.22.71 Chromium: 89.0.4389.114 (Official Build) (x86_64)
7 Likes

Was about to report this bug, I was trying like for 15 minutes to do the shortcut for text and thought it might be my Non-US keyboard, thanks!

2 Likes

Hey there! Please check out this post :point_down:

4 Likes

All shortcuts using the number-row characters (/, +…) do NOT work on non-QWERTY keyboards even in Figma. If it’s a bug it’s present in both products for ALL such shortcuts.

1 Like

1. Describe the bug/issue you’re running into?
The shortcut for cursor chat is / which is not an individual key on german keyboard layout. To write / I have to press shift + 7.

1. Describe the bug/issue you’re running into?
To start Cursor Chat you have to press /
This is not possible with a German Keyboard (where it is shift+7), nothing happens. Btw this makes it also impossible to use Quick actions in a Figma file

2. Are you able to consistently reproduce it? If so what are the steps?
yes

3. Share a screenshot, recording, console log, link to the file, etc.

4. Is the issue only happening in desktop app or a specific browser , or both?
both

5. What OS/version and/or browser/version are you using?
Mac OS, Figma desktop app, Safari 14.03

1. Describe the bug/issue you’re running into?
To start Cursor Chat you have to press " / "
No access to this feature with a French Keyboard (where it is shift+:/), it’s only makes the arrow cursor diseapear and then nothing happens. Have to use E to to the Corso Chat.

2. Are you able to consistently reproduce it? If so what are the steps?
Yes

3. Share a screenshot, recording, console log, link to the file, etc.

4. Is the issue only happening in desktop app or a specific browser , or both?
browser

5. What OS/version and/or browser/version are you using?
Mac OS, Safari 14.03

1. Describe the bug/issue you’re running into?
I can’t use the command to use the chat, but I can using the other methods:
clicking E and then selecting the chat or manually with the cursor.

2. Are you able to consistently reproduce it? If so what are the steps?
I’m trying to active the chat using / but I can’t.

3. Share a screenshot, recording, console log, link to the file, etc.

4. Is the issue only happening in desktop app or a specific browser , or both?
both

5. What OS/version and/or browser/version are you using?
latest one.

Same here :raised_hand: . Non US keyboards makes shortcuts based on “/” impossible to type, as the “/” is used under shift+7 combination.

So something easy to trigger as the chat feature is incredibly hard to use (only option is to rely on the top-right :sparkles: actions menu)

1 Like

Figma ever has had issues with ISO keyboard layouts. Quick Actions is still not working and I reported it a year ago.

1. Describe the bug/issue you’re running into?

I have a German Keyboard. “Quick actions” is triggered via the “/” key. But on ISO Keyboard Layouts (Pretty much 90% of the world out side of the US) you have “Shift + 7” to create a “/” symbol. But this doesn’t do anything.

Bottom line: The quick actions and the cursor chat function is literally not accessible in any way for anyone outside the ANSI region.

2. Are you able to consistently reproduce it? If so what are the steps?

Yes. Set your keyboard layout to Germany for example (many ISO Layout should reproduce this) and try to use “quick actions” or “cursor chat”. It’s not possible.

3. Share a screenshot, recording, console log, link to the file, etc.

4. Is the issue only happening in desktop app or a specific browser , or both?

Anywhere.

5. What OS/version and/or browser/version are you using?

macOS Big Sur (11.2.3)

2 Likes

Hi @IServ_GmbH :wave: Thanks for reporting this issue, merging your post into an existing one about the same topic.

Please see the message below about this bug:

Thank you! Looking forward for this to get resolved :slight_smile: Switching to US Layouts is not really feasible. It would mean I have to constantly switch back and forth if I want to use Umlauts or write any special characters.

1 Like

The issues is also in Figma not just FigJam. You should escalate.