Library issues - component won't update

Hopefully someone can help me. For the last several days I have been having an issue with one of my components in my shared component library. I have been actively making changes and publishing them to the shared component library to use in a separate Figma file. Both the Library file and the separate file have a blue icon under Assets > Updates for this one component. The grey update button doesn’t work. When I click it nothing happens. The blue “update all” button simply dismisses the window, but the component update notification is still present.
asset button issue

I have tried

  • deleting and restoring the component
  • renaming the component
  • updating other components and publishing all changes to the library
  • closing and re-opening Figma
  • restarting my computer

Any thoughts on how to resolve this?

Also, another weird thing I observed… most of the components in the Library file are in the “Local” component list. Why are some listed separately when they are from the same file?
TIA

1 Like

Here is the other component image ( I couldn’t attach above)

1 Like

I’ve been having this same problem today, and I have no idea why it’s happening! It’s really annoying though! I hope @Figma_Support can fix it!

1 Like

Having the same issue

Same issue here

I have been trying to update the component from the library for nearly a week, the same problem((

Same here :frowning:

I’m facing the same problem. Updated MUI library with my own color theme and component styles and published the library, now trying to update those components being used in another file but no luck T-T

+1 Same issue. @Figma_Support ?

+1 any news on this? @Figma_Support

Same issue :frowning:

The same issue, components are not updating across files with a shared library!!

Same issue, improved component in the library>Published library> updated component in project file but the component in questions doesn’t update in the file or from the assets panel.

Scratch that, I just realized I had conflicting overrides names which didn’t get flagged. I corrected and all is good and the project files are updated.

I ran the “search by name” plugin on each page of the project and found a component that was not updated in the hidden layers

I have exactly the same issue. It’s super annoying. Any fix yet?

The same issue. Found the solution. I created a new file and was moving artboards one by one to it until I got the “update” message again at the new file. That is how I found the broken artboard. The broken component on this page was at the hidden layer, so I unhided all layers with component, then updated library (or you could try “reset all changes”) and the problem gone.

Seems like hidden components have some updating issue.

Same issue. @Figma_Support

Same for me as well. @Figma_Support

Same issue @Figma_Support