Figma Support Forum

Can't restore earlier versions after getting the 'File out of memory' error

Hi everyone.

We faced the issue with reaching the limit of the file size and can’t roll back to the earlier versions.

The case is that I work in the file with 2 other people. Let’s say they made their edits on the 6th of Sep, then on the 8th, etc. Finally after edits on the 14th we saw the ‘File out of memory’ error. Ok, we tried to restore the Sep 8th version - same error, Sep 6th - same error.

Any ideas on how could that happen (I mean older files getting the same error) and how it can be solved?

The file is not opening in neither browser (chrome) nor in the desktop app (no other tabs are open in parallel).

Thanks in advance for any help/advice.

Are you trying to restore a version from an open file? Try to restore the version from File Browser as described here: https://help.figma.com/hc/en-us/articles/360040528173#100

Ye, was trying from an open file.
Have just tried to follow your advice but unfortunately the same result.

I’m getting a similar error, except it’s only when I try to go back to a previous version that it says “out of memory” and then won’t restore any version, even the current one. A few weeks ago, when I had less in the file, it wasn’t out of memory, but going to previous version doubled the memory usage (to like 60%), and then going back to the current version cut it down to 30%, so I’m also wondering why they’re both being loaded at the same time.

Same problem here.

The resource usage monitoring tool does not show how much memory is being used.

20 days ago I lost the first file, and I also couldn’t restore it to a previous version. I had to go back to the day before, that is, I lost about 10 saves.

Today, 4 more files corrupted the same way, without any prior notice, they simply jumped to 100% memory usage, and I can’t recover any, I lost several saves and dozens of hours of team work.

What helped is to limit my permissions to read only in the project where the corrupted file was located. After that I managed to open that file (the memory error didn’t appear) and copy-paste the content into 3 other files which I created in another project. Then I got my permissions back and moved the new files to the proper project.

Hope it will help

FYI @Rodrigo_da_Silva_Alves

1 Like