Bring to front feature does not seem to be working consistently

Using ‘Bring to front’ option to try to bring text to front in figjam, but it does not seem to be working. Instead I had to bring other elements back.

2 Likes

Make sure that none of the elements have “Fix Position While Scrolling” Enabled.
image

That will always put certain things in front of others. If you have one of those enabled, and are working with a layer that doesn’t have it on, it will ALWAYS be under it. You can see that in the layer sidebar as well.
image

1 Like

I am also having this issue. I tried @Hunter_Paramore 's solution but it did not fix the problem. I have noticed that this tends to happen when copy-pasting elements and groups from one frame to another, maybe that’s the source of the problem?

1 Like

I experience the same problem and would REALLY appreciate getting it to work - since I’m switching just from adobeXD and am really used to use it.
When I press the shortcut ‘]’ it doesn’t bring the object to front but changes the opacity.
Shift + ‘]’ == changes zoom to fit… it only work via R-click and selecting it in that pop up menu. So there’s no issues with the arrangement of the object or the “Fix position when scrolling”

1 Like

I have just encountered the same issue due to copy/paste of components from one frame to another. I noticed that the pasted objects are not always subordinated to the frame in which I placed them and this is why they will always remain in the top layer. After I dragged them in the left panel to be subordinated to the correct frame, sending back/front worked properly.

1 Like