Figma Support Forum

Updated Text styles aren't getting applied

One of our designers ran into this problem when we updated all our text styles in our library with a new typeface. Now in most (if not all cases) the new text styles aren’t getting applied automatically.

Now you either have to manually select the text and the element updates itself or you have to choose another text style and then re-select the right one (that was previously applied).

The text elements still have the correct text style applied, but they aren’t updated.

What could be the reason for such a behaviour?
It would be a pain to go through our file and manually select each text layer to update/refresh the style.

5 Likes

Is this what you are facing? Font changes by double clicking and copy-paste

Try it:

If you still encounter a problem, then write a bug report to the support service.

I heard about this issue from a different user. You may want to record a video and send it along with other details and links to Figma support team via the bug report form.

The recomputing of the text layers works, as in fixes it after.
I’ll try to write a bug report in the next days.

I’m having this same issue. Why would not update the text styles?!

Any chance you used the plugin Batch Styler when you updated your old styles to a new one?

Hi guys, faced the same issue. Have you found a solution?

Personally I haven’t encountered the problem again, as it seems to require specific circumstances. As I wrote in my last reply - the recomputing of the text layer fixes the issue.

Had the same Issue and was indeed using Batch Styler Plugin. Could be the cause.
Figma was not showing any changes made to the styles (Line Height). Fixed it by adding a strikethrough, doing a publish then removing it again with another publish. All done by the native interface. Then it updated and recognized the line height change as well.