File data erased/lost after upgrade - Figma Desktop App version 116.15.4


This morning I got a pop-up to upgrade (to Figma Desktop App version 116.15.4.) I’m using MacOS 10.15.7.

Prior to upgrading, I was working on a file that I have been working on since the 11th of November.

I finished working on the active file and then initiated the upgrade.
I did not close the active file.

After the upgrade, the file is completely empty and has been reset to the way it was when I imported it on the 11th.

I have tried going into the version history.
There is a list of 25 auto-saved versions.
When I view or restore a previous version, none of the versions show anything other than the original file data from the 11th.

I have tried re-booting the machine (even though the files are stored on the cloud and that shouldn’t really make a difference.)

I have tried accessing Figma using Chrome (Version 119.0.6045.159) and I get the same results.

Any help here would be appreciated…

Hey, sorry to hear this happened! Can you take a look at Can I work offline with Figma and double check that you don’t have any offline changes waiting to sync, and also read the section ‘Offline changes not saved’ which calls out what might cause changes not to be saved

If you do not have any offline changes, can you please reach out to the support team directly via this form for help:

Be sure to use your Figma account email, include a link to the file, and share it with so they can take a closer look.