Figma Support Forum

autoRename not working on instances?

So my plugin, Reset Text Layer Name, has worked for the longest time without any issues, but recently I noticed that it isn’t able to work on component instances?? Was this a recent change to the API? It’s been a long time since I actually got into the code, but wanted to reach out to see if anyone was aware of any changes that might cause my plugin to not work on component instances anymore.

You’ll see if you open the Figma community page for it, even the animated GIF I show at the top, shows it working with instances.

Note: I am trying to update to the latest version, but it won’t get past version 14 with npm install --save-dev @figma/plugin-typings . Why is that?

Bug ticket:

I’ve created a bug issue in my repo if anyone wants to help out through that method too: Fix autoRename not working on instances · Issue #1 · megaroeny/Figma-Reset-Text-Layer-Name · GitHub

Thanks for any help!

I have no information on the “autoRename” property. But to quickly fix the plugin’s functionality, you can do this:

// node.autoRename = true;
node.name = "";
1 Like

That worked, thank you!! What’s funny is that I initially had that for my plugin code, but changed it later on. I replied to your comment on my bug ticket too.