Figma Support Forum

Why is WebGL still not working after updating Chrome flags and relaunching?

Hello - I’m still getting the WebGL not supported error message even after following the instructions in the help article. I have updated my Chrome flags as attached and relaunched Chrome. Would appreciate any help!


Screen Shot 2021-06-07 at 12.46.42 PM

1 Like

Same is happening here!

No response from support? This issue is happening on MacOS Chrome as well

Could you check the Graphics Feature Status by opening chrome://gpu/? What is the status of WebGL and WebGL2?

Thanks for the response.

  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

Chrome Version: Version 97.0.4692.99 (Official Build) (x86_64)
OS: macOS Monterey 12.1

Loading a figma file gets Chrome to a non-responsive state, and then shows the error that was posted by the others in this thread.

Does Chrome on MacOS have a “Choose ANGLE graphics backend” flag (chrome://flags/#use-angle)?

Yes there is.

Currently set to Default.

I set it to OpenGL, same result as Default.
I set it to Metal, it can load the document, but the entire Chrome is finicky, so probably not a good option.

This flag has a warning:

Choose the graphics backend for ANGLE. The OpenGL backend is soon to be deprecated on Mac, and may contain driver bugs that are not planned to be fixed. The Metal backend is still experimental, and may contain bugs that are still being worked on. The Metal backend should be more performant, but may still be behind the OpenGL backend until fully released. – Mac