Hidden elements should not be visible in outline mode

Hidden elements pollute the outline view, and show up in an arbitrary location and layout. This is especially bad for the new components with visibility props. For instance, buttons with hidden icons are still visible in outline mode.

You can exclude hidden layers. Just uncheck this setting:
Menu › ViewOutlinesInclude hidden layers.

2 Likes

Thanks @tank666 was looking for exactly this. And thanks @Raphael_Guilleminot1 for flagging this!

I find in a lot of circumstances the hidden layers are actually super helpful in outline mode (however…) it would be great to have a quick command/key binding for quickly showing or hiding them when working in Outline mode.

Having to navigate through a rabbit warren of menus each time isn’t ideal if you want to switch back and forth a few times a minute.

Hopefully Figma continue to refine these new features :smiley:

For faster access, you can use Quick actions by writing “Outline” in the input field, and then switch between the last three actions.

1 Like

@tank666 Thank you so much for that!

I’d still vote for having hidden objects disabled by default. Or at least not being reset to “show” each time I open a file