Figm always opening from same obscure folder instead of default

Hi,

Basically, whenever I open the Finder through Figma to upload an image for example, I would like Figma to open from the default folder I set in my Finder settings (which is Downloads). Yet for some reason, Figma always opens on some ‘deep’ folder I created months ago for one of my first projects. It’s getting quite annoying and inefficient at this point. Any ideas on how to change this?

Sadly I couldn’t find an answer or similar questions, so here I am. A few months ago I completely switched from XD to Figma and started working from a MacBook I got from work (which already annoys me by itself from time to time). I wouldn’t be surprised if this is an issue with Mac, though it only seems to happen within Figma.

Thanks in advance!

2 Likes

I have had this same issue on Mac for months on end, maybe some day they will fix this for us. :sob:

Even just a setting where we can choose a default folder within the Figma UI would be great, since I have never found this mythical preferences file to edit.

Forgot about this thread. IIRC I fixed it by relocating the folder somewhere else, restart Figma and try choosing a file again. It should reset and you can put the folder back to its original place :slight_smile:

I organise my desktop folder by project so all the assets for a project are within that folder. I want to be able to navigate to my assets folder for the project I am working on and for Figma to remember that path. I keep getting taken back to an old project sub folder. I don’t want to have only one folder on my Mac where all images for all projects are stored. That’s crazy. Is there a proper fix for this?
Thanks!

Hey @Karen11 , have you tried the fix I suggested to someone else?

Temporarily relocate the folder Figma currently opens by default and restart the program. After this you can put the folder back and Figma should open the file browser like normal again.

Hi @Yannis_PandaPanda
No, it didn’t work for me. I contacted support and they said to clear the cache, which I did via the Terminal and now it’s working – for now anyway! Of course I had to log back in afterwards and lost some preferences but at least I know what to do if it happens again.

@Yannis_PandaPanda I tried your suggestion and it only bumped me up one in the path structure (the outer folder where the folder used to exist), marginally better but not really a fix. I also noticed that after I restored the folder to where it’s supposed to live in the path, Figma automatically started putting me back in the original problem folder again. :thinking:

Oh okay, that’s annoying indeed … Perhaps you can try what @Karen11 suggested above

Hi @gj-jay – try what Figma advised (if on a Mac):

Here’s how to clear the desktop app cache on a Mac:

  1. Quit the Figma desktop app
  2. Open Terminal.app and enter the following command: rm -rf “$HOME/Library/Application Support/Figma”
  3. Try opening the desktop app again and attempt to add the images

It worked for me!

@Karen11 Thanks! I got the same instructions from Figma Support and it didn’t seem to do the trick for me. They gave me an alternate way to delete the Preferences file directly, which worked for me:

  1. Quit the Figma desktop app
  2. Navigate to ~/Library/Application Support/Figma/DesktopProfile
  3. Inside, there should be folders with version numbers - open the folder for the latest one
  4. Delete the file labeled “Preferences”
  5. Restart Figma

Thanks! I’ll save that method too!