Figma Support Forum

Desktop Agent Not Running

The Figma Desktop Agent is not running and Figma support has not responded in over two months since a request was put in.

I need this to be able to have the links automatically open in the desktop app. Any ideas on how to ensure the agent is installed and running properly?

Big Sur: 11.1

@Brad_Larson Did you get this resolved?

@Josh this was an issue with Brave Browser - might not to have that listed somewhere. Anyhoo - thanks for following up. This is now resolved.

1 Like

What was the solution? I still can’t get Brave to identify that the Figma desktop app is available.

Here’s my issue: I want to go straight from Figma links to the Figma desktop app. (Their browser app is less performant, feature constrained.) Clicking Figma links only opens the web app, with no option to favor the desktop app. Opening the Figma menu has an option for “Get desktop app” even though I’ve already downloaded the app. The Figma preferences menu should have an option to Open in desktop app - it does not. None of these issues occur on Chrome, Safari.

How can this issue be reproduced?

  1. Have a Figma project link
  2. Open the Figma link
  3. Browser opens the link in Brave

Expected result:
The Browser should open the link in the Figma desktop app

Brave Version( check About Brave ):
Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (x86_64)

Additional Information:
MacOS Big Sur 11.1

@Erik_Peterson did you turn shields off for figma website - that was the solution for me.

I also had issues with the “Open in desktop app” functionality. This should be added in this support article. It’ll help a lot of Brave users.

3 Likes

Do you mind providing the specific steps to turn off shields in Brave? Is it just for Figma?

@Keven_Lupien click the Lion face in your url bar, and you’ll be able to disable the shields just for Figma. Hope this helps.

@Brad_Larson Yes!!! Thanks so much. I just started using Brave so I didn’t realize that was there. I was going into Preferences and poking around there. This is so much easier. Much appreciated.

1 Like