Can't open links in desktop app / Figma web won't detect desktop app

Hi everybody,
I’m having trouble opening links (from our team slack or email) in the desktop app, like it used to work. I also realized I no longer have the option in the web app to open links in the desktop app. I only get an option to download the desktop app, which I did for about five times. I also logged in and out for about five times and restarted my computer, but it won’t work. Any help would be DEEPLY appreciated, as this is such a waste of time and I have to rely on several workarounds.

MacOS Monterey (12.0), current Figma version, 107.1

Kind regards
Florian

I’m having the same problem. Any link I click on just opens in the browser. And the preferences on the web app don’t show the option to open in the desktop app.

I’ve reinstalled Figma, restarted my computer, restarted Figma, etc. All the things.

I’m using Brave (Chromium-based) as my browser. It was working previously in Brave, but now it’s not. I just started using a new M1 Macbook Pro (Apple silicon) and it hasn’t worked – my setup where everything was working was on my old Macbook Pro (Intel) – that’s the only thing I can think of that might be diferent.

Considering using a Chrome extension to fix this (Open in Figma - Chrome Web Store) - but that just seems way hacky to me to get a ‘native’ preference to work.

MacOS Monterey 12.2 / Figma 107.1 / Brave 1.35.100 (Chromium 98.0.4758.87)

1 Like

Ha! I’m also on Brava, maybe I’ll try another browser… Thanks @Miller_Ryan

Hey @Flo and @Miller_Ryan - since you’re both using Brave, do you have Shields up when using it? That may be why you’re hitting issues with Figma links.

You may be able to adjust the Shield settings: this link may help more.

1 Like

@knishida - good suggestion. I turned Shields off for figma.com, reloaded the page, and the preference still isn’t available. I restarted the browser, same result.

1 Like

Interesting! Thanks for the report :face_with_monocle: I’ll note this for the team. If any other suggestions come up after, I’ll make sure to post again!

1 Like

Not sure what changed, but I’m seeing the preference now, and the mini dialog asking to open in desktop or not…

Tested a link, and it is now opening in the desktop app.

For me too, however, I was using safari instead of Brave. I’ll try again with shields down in Brave.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.