Figma Support Forum

[BUG] "Show in Exports" doesn't work in Variants

I still see fill in Exports and also if use instance of this Variant

To report a bug send screenshots and the example file to Figma support team via the bug report form. I cannot reproduce this behavior though, maybe you can share the example file here?

Thanks, Gleb. The issue happens when I use an instance of this component in other frames. Is it supposed to show fill color when I use it in other frames?

I don’t care much about Export itself. I need to hide background color in instances as Sketch does. With such background color, we can see the edges of the component frame and how visible content aligns to borders.

And more. In Assets view, I see it without red:

Ah, I see. This checkbox only affects exports, there is no checkbox for background showing in instances like in Sketch. It’s not a bug, just a lack of feature. You can create a new topic with the suggestion in #product-ideas category.

yep, but it doesn’t work in inherited usages. I have a component with Show in Exports=OFF and exporting frames with instances of this component has fill color in Export.

That’s not how this checkbox is meant to work. It only affects the export when you export the object itself, not a frame that contains it. That’s why this checkbox doesn’t even show up when the object doesn’t have export settings, since it doesn’t affect anything else.