Figma Support Forum

Why are Color Styles sometimes not appearing in library?

Frequently when I publish my library I find color styles missing. It’s usually the same color. It appears to already be missing when I go to publish the library.

Here it is in my color styles panel in the library file:
Screen Shot 2021-03-23 at 12.02.21

And when I go to publish it, it’s not there:
Screen Shot 2021-03-23 at 12.02.38

I’ve tried changing the color and publishing, then changing it back, but it still doesn’t work.

Am I missing something?

In the publishing window you can choose which styles and components to publish:
Publish library window → right click, Remove from library

They could’ve been removed either manually or accidentally because of the dot in the name (when the Style or Component name starts with . or _ it is removed from publishing).

Hmm, ok, that’s really good to know, thank you. It’s possible someone accidentally deleted it at some point.

I removed the color style and created a new one, and then relinked all the instances of that color with the Style Organizer plugin. It seems to have worked. Let’s hope it stays that way.