Smart Animate seems busted after latest release... is anyone else seeing this?

I’ve been working through a fairly light file and all of a sudden as of yesterday when my local client updated I’ve been see really janky animations from smart animate. It looks like the animation for hiding and unhiding elements is computing their position incorrectly and then recomputing it, plus the hidden elements just snap in.

I assume this is a bug?


also, tried to share a video of it but “new users can’t share attachments” womp womp…

I came back to a project after leaving it untouched for about two weeks and am experiencing the same thing with push animations. I have “animate matching layers” checked off, and the matching layers animate just fine (in my case, this means they don’t move at all) but every other layer moves unexpectedly, some of them just snapping in like you said.

I went back into my version history in case it was something I’d unknowingly done, but nope. Past versions of my project that I’m certain were working seamlessly are now broken as well. Really hoping this can be fixed as it would be unfortunate to have to redesign everything around this issue.

1 Like

It seems like you’re encountering unexpected behavior with the smart animate feature, it can be a bug.

Hi @sarah67 Here are a few suggestions:

  1. If you’re using the desktop application, try restarting your computer, If you’re using the web version, try using the app in “incognito” mode.

  2. If you know someone else using Figma, try sharing the file with them and then access the design through their PC to see if you can replicate the error.

  3. Try logging into your Figma Account via another computer entirely.

If you can still replicate the error, then, it may actually be a bug. If this is the case you can pass it on “Support”

if it’s not a bug, I hope someone who has experienced it before can share how they fixed it.


1 Like

@Support_Team Yep, looks like this is a bug. It’s across several users, and I can replicate it across several devices and via the desktop app and the browser.

Yep. I also tried version history, and even old versions of the project are broken for me…

Glad to know I’m not the only one experiencing this. I have a simple smart animation that was working perfectly two days ago now it glitches on every device…

1 Like

Blargh. Can we get a bug number for this or something?

Yes, experiencing this as well!

Hey everyone, apologies for the issues! Please contact our support team with a copy of your file. Please add as an editor on your file so our technical quality team can take a closer look. Also, please attach a screen recording.

Here’s a screen recording. I have a support ticket open… this is after I rebuilt the components from scratch. This is happening across all my files anywhere I have smart animate, unfortunately.

The glitch seems to be fixed for me!

Hey! Thank you for filing a support ticket. Our technical quality team will take a look at it.

It’s fixed for me as well. Thanks everyone! :smile: