Figma Support Forum

Shadow Effect Problem

Hi,

Having a strange bug(?). When adding a drop shadow effect to a component, the ‘spread’ property is disabled (greyed out). This happens only on some components, and it seems to be affected by the way they were built.

I managed to recreate this bug like this (not sure this is the reason):
A make frame → make component → apply shadow : fine!
B make rectangle → make component → apply shadow: no!
C make rectangle → make component → delete rectangle layer in component → apply shadow: no! (this is same exact component as A)

This really makes the spread feature unusable, I need it for custom styles and states…
Any thoughts or help?

When you hover the disabled spread property, it will tell you why it’s disabled. In this case specifically it will be disabled when your frame/component doesn’t have a solid background and when it doesn’t have clip content checkbox enabled.

Wow missed that… Thanks!